[gmx-users] atom type error

Haerterich, Steffen haerterich at apollo1.pharmazie.uni-erlangen.de
Fri Jul 16 07:27:13 CEST 2004

The Problem with DPPC and the standard GROMACS forcefield is that for example the 
bonds between CH3 and NL which are used to describe the ammonium-head of DPPC 
are not defined within the forcefield (within ffgmxbn.itp if I am not mistaken).
I guess by the atomtype 'LC3' that you are using the dppc.itp from Tieleman's website.
He introduces some new atomtypes for the lipid-atoms which are not defined within the 
forcefield. So you would have to include his lipid.itp within your topology, too.
However this file is incompatible to the new versions of GROMAX due to a second 
[default] section.
A solution for this is to download the ffgmx_lipids.tar.gz from the topologies part from 
the gromacs-homepage. It seems that the lipid.itp-Parameters are included in this 
forcefield and it works fine with the popc.itp, dppc.itp, etc. from Tieleman's website.
(I took this information from a recent discussion within the gmx-users mailing list)

Link to forcefield-download: 
(Thanks to Bert de Groot who uploaded this file!!!)

If you want to use a different forcefield you will probably have to explicitly declare the 
atomtypes, bonds, etc. you are using within the dppc.itp / your own lipid.itp / the 
[forcefield].atp or stick to those already implemented within the forcefield. (I think the 
modified ffgmx43a2-forcefield uses LCH2 and LCH3 to describe the aliphatic chains but 
I am not sure)
I hope this is of some help to you.


On 15 Jul 2004 at 13:28, Dinesh Pinisetty wrote:
> Hi everyone,
>        As christopher told I tried all permutations and combinations
> arranging the #include files,when I used #include lipid.itp,#include
> ffG43a1.itp,#include dppc.itp in this order now I am getting error as
> Atomtype 'C' is missing only the atom name is changed rest all is the same.
> when I used ffG43a1,dppc.itp,lipid.itp 'LC3' atomtype was missing and when
> I used ffG43a1.itp,lipid.itp and dppc.itp I was getting error as 'LC3'
> atomtype was missing.I do not think mistake is in there.
>  Please suggest me what to do now.............
> Thanks in advance........
> It may do with the order that you included your itp files in your top file.
> If
> the atom definitions for DPP are in lipid.itp, then make sure lipid.itp is
> included before dppc.itp.
> Also, have you checked out Tieleman's site for lipid coordinate and
> topology
> files?
> Christopher Tran
> chr.tran at utoronto.ca
> Quoting Dinesh Pinisetty <dpinis1 at lsu.edu>:
> >
> >
> >
> >
> > Hello everybody,
> >           I have been trying to run MD simulation for dppc membrane with
> > water molecules.Intially when I run pdb2gmx for .top and .gro files it
> gave
> > me an error saying that the residue DPP was not there in residue topology
> > database.Then I created my own dppc.itp file and lipid.itp file and added
> > it to the incomplete .top file created by pdb2gmx.I created .gro file by
> > editconf.When I run grompp I am getting an error as
> >           processing topology
> > Generated 279 of the 1225 non-bonded parameter combinations
> > Cleaning up temporary file gromppG9xnJE
> > Fatal error:Atomtype 'LC3' not found
> > But I have this atom present in dppc.itp and even added in ffG43a1.atp as
> I
> > was using ffG43a1 force field.Should I add anything more anywhere.
> > Please let me know where I might have made a mistake.
> > Thanks a lot in advance..................
> >
> > Dinesh........
> >
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20040716/64dd0289/attachment.html>

More information about the gromacs.org_gmx-users mailing list