[gmx-users] Compiling on power4, still struggling

Pim Schravendijk schraven at mpip-mainz.mpg.de
Tue Jul 27 16:13:15 CEST 2004

I tried installing gromacs 3.2.1. another power4 system than the one that 
didn't really install well, it should be the same system, but nothing 
bad with giving it a try.... I also tried installing with gcc 3.1 on 
another power4 where any xlc installation failed until now.

# installation on a new, fresh, power4 machine:

Installation and check of the single precision fftw goes fine as usual, no 
problems there. I use the CPP an LD flags to link to the fftw includes, 
libraries, and MASS libraries. No CC environment is set, this means that 
xlc version 6 is used.

The first strange thing that happens is the long time it takes to check at 
this point:

>checking for pthreads... yes
>checking how to get verbose linking output from f77... 

Then I get a warning here:

>checking whether f77 accepts -O3 -Q -qarch=pwr4 -qtune=pwr4 
>-qmaxmem=16384 -qhot -qnoipa... ** f   === End of Compilation 1 ===
>1501-510  Compilation successful for file conftest.f.
>* Sorry, these optimization settings don't seem to work for       *
>* your f77 compiler. Use make FFLAGS=.., or edit the top Makefile.*

After the end of configure I try to make and it tells me:

>/usr/include/unistd.h", line 171.17: 1506-050 (I) Return type "long long" 
>in redeclaration is not compatible with the previous return type "long".
>"/usr/include/unistd.h", line 171.17: 1506-377 (I) The type "long long" 
>of parameter 2 differs from the previous type "long".
>"/usr/include/sys/lockf.h", line 64.20: 1506-343 (S) Redeclaration of 
>lockf64 differs from previous declaration on line 62 of 
... etc

A similar problem was on this list earlier, so I installed with 
--disable-largefile, it actually compild with this, but running the 
d.villin benchmark with this gave me the following output:

>step 0Warning: 1-4 interaction between 1 and 7 at distance larger than 1 
>nm These are ignored for the rest of the simulation
>turn on -debug for more information

After which the simulation halted. As what should I give the -debug flag 
with? It isn't recognized by ./configure... Should it be a CFLAG?

In any case it's something that shouldn't happen. I tried with 
--disable-fortran but that lead to the same results. I would be really 
glad if this power4 installation would work, if the power4 resultss are 
just as promising as the mac ppc results, it would really boost the 
computing speed of my runs compared to the athlons which I'm using now.

# the one on which I tried installing with xlc already, but this time 
tried with gcc:

Here I used "setenv CC gcc" (gcc -v gave: Thread model: aix, gcc version 
3.1) with "setenv CFLAGS -03qarch=pwr4qtune=pwr4", this according to:

It configures nicely, but during make something like this happens:

Making all in src
        make  all-recursive
Making all in gmxlib
        if /bin/sh ../../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. 
-I. -I../../src  -I/usr/include   -I../../include 
-I/u/schraven/gromacspower4/fftw215/include   -03qarch=pwr4qtune=pwr4  -MT 
3dview.lo -MD -MP -MF ".deps/3dview.Tpo"  -c -o 3dview.lo `test -f 
'3dview.c' || echo './'`3dview.c;  then mv -f ".deps/3dview.Tpo" 
".deps/3dview.Plo";  else rm -f ".deps/3dview.Tpo"; exit 1;  fi
Waiting for 3dview.o.lock to be removed
Waiting for 3dview.o.lock to be removed
Waiting for 3dview.o.lock to be removed

The file with a .lock may differ at different tries. This might well be a 
problem due to the local configuration, maybe someone here has a clue how 
to avoid this problem? 

Greetings, Pim

Pim Schravendijk - PhD Student
Max Planck Institute for Polymer Research

More information about the gromacs.org_gmx-users mailing list