[gmx-users] Error when reading xtc trajectory

Christian Burisch burisch at bph.ruhr-uni-bochum.de
Tue Aug 16 16:26:28 CEST 2005

Hello everyone,

in some Gromacs 3.2.1 tools (namely g_dist and trjconv in my case) we 
encountered the following or very similar errors:

Reading frame       0 time    0.000   *** glibc detected *** double 
free or corruption (!prev): 0x081de720 ***


Reading frame       0 time    0.000
Precision of md.xtc is 0.0001 (nm)

*** glibc detected *** double free or corruption (out): 0x08255198 ***

In all cases we tried to read xtc trajectories (tried several from 
independent runs) with xtc_precision=10000 in conjunction with a tpr 
file (which of course is mandatory for g_dist and could be avoided by 
alternatively using a gro file for trjconv). In trjconv the error only 
seems to occur when I use the -fit rot+trans flag.
Gromacs, fftw and mpich_gm were compiled from scratch under SuSE 9.3 
with gcc version 3.3.5 20050117 (prerelease) (SUSE Linux) and glibc 2.3.4.
The error still shows (with the same xtc file though) when I compile 
Gromacs with no fancy configure options and without fftw/MPI support.

Thanks in advance for any help or comments


More information about the gromacs.org_gmx-users mailing list