[gmx-users] libXm.so.1 Gromacs Help

Sabuj Pattanayek sabuj.pattanayek at vanderbilt.edu
Sat Mar 19 22:59:00 CET 2005

I have gromacs working on gentoo x86:

1) make sure you have the latest version of the portage/ebuild tree. You 
can do emerge --sync to update it
2) then do emerge -av gromacs openmotif
/root# emerge -av openmotif gromacs

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] sci-chemistry/gromacs-3.2.1  +mpi +xml2 0 kB
[ebuild   R   ] x11-libs/openmotif-2.2.3-r3  -debug 0 kB

Yes to emerge the packages

make sure openmotif gets compiled before gromacs, because gromacs will 
link to the libXm from openmotif. You can see here that it is provided 
by openmotif.

/root# qpkg -I -l openmotif | grep libXm
/usr/lib/libXm.so.3 -> libXm.so.3.0.2 1109821261
/usr/lib/libXm.so -> libXm.so.3.0.2 1109821261

/root# luck
"Have a Nice Day" (R. McDonald)

..Sabuj Pattanayek

supakar at spymac.com wrote:
> Hi ALL
>        could anybody help me !
>        I have installed gromacs on IBM Power PC (64 bit) with Gentoo as OS but
> when i try to run any command eg. luck / pdb2gmx the ERROR mesege shown is : 
> prompt>
> luck: error while loading shared libraries: libXm.so.1: cannot open shared object
> file: No such file directory
> prompt>
> I have also tried to recover by installing open motif (openmotif2.1.30)and
> lesstiff(lesstif-0.94.0) but it showed the same error .
> _______________________________________________
> gmx-users mailing list
> gmx-users at gromacs.org
> http://www.gromacs.org/mailman/listinfo/gmx-users
> Please don't post (un)subscribe requests to the list. Use the 
> www interface or send it to gmx-users-request at gromacs.org.

More information about the gromacs.org_gmx-users mailing list