[gmx-users] Problem in mdrun_mpi using MPICH

Alok alokjain at iitk.ac.in
Wed Oct 19 15:25:46 CEST 2005

Greeting to All,

sorry for very silly question.I have very limited knowledge of parallel

I am trying to install parallel version of gromacs 3.3 in SUN Cluster.I
compiled  fftw,binutis & gromacs 3.3 without any error.

MPICH was already installed on the SUN Cluster.

when i run grompp_mpi for 2 node it ran fine and generated the *.tpr file
for two processors.

But i tried to  mdrun_mpi -h it gave following message.

It seems that there is no lamd running on this host, which indicates
that the LAM/MPI runtime environment is not operating.  The LAM/MPI
runtime environment is necessary for MPI programs to run (the MPI
program tired to invoke the "MPI_Init" function).

Please run the "lamboot" command the start the LAM/MPI runtime
environment.  See the LAM/MPI documentation for how to invoke
"lamboot" across multiple machines.

Due to boundation of out computer center rules i could not use the
"lamboot" command. I have to submit the job by using following script
(provided by our system administrator)


#!/bin/csh -f
# (c) 2004 Sun Microsystems, Inc. Use is subject to license terms.

# ---------------------------
# our name
#$ -N MPI_Job
# pe request
#$ -pe mpich* 2-20
# MPIR_HOME from submitting environment
#$ -v MPIR_HOME=/opt/mpichdefault-1.2.6
# ---------------------------

# needs in
#       the number of tasks to be used
#   $TMPDIR/machines
#       a valid machine file to be passed to mpirun

echo "Got $NSLOTS slots."

# enables $TMPDIR/rsh to catch rsh calls if available
set path=($TMPDIR $path)

$MPIR_HOME/bin/mpirun -np $NSLOTS -machinefile $TMPDIR/machines -nolocal *


and start the job by using following command.
qsub -pe mpichpar <no of nodes> -q par.q <script_name>

where * is Path of the input file including parallel program name (in my
case it is /users/alokjain/mdrun_mpi -s full.tpr -o full -x full -c
after_full -e full -g full)

but it is not recognizing the mdrun_mpi command.(I already set the path)

can some one help me to overcome this problem?
Is there some problem in installation or in the script?

Thanking you,
Best regards,
Alok Jain

More information about the gromacs.org_gmx-users mailing list