[gmx-users] REMD

Mark Abraham mark.abraham at anu.edu.au
Thu Apr 13 07:17:30 CEST 2006

> Dear gmx users:
> I am trying to run REMD with two replicas (for testing). I used
> grompp -f -c -p -o replica0 to get replica0.tpr
> grompp -f -c -p -o replica1 to get replica1.tpr
> then used
> mdrun_mpi -np 2 -multi -replex 500 -reseed -1 -s replica -deffnm replica
> -v -N 2
> to run it.

mdrun doesn't take '-N 2' but I'm not sure this is the problem. Otherwise,
looks fine to me.

> I got an error message "Segmentation fault" from my script output, but
> no error message in both log files. When I tried to run individual tpr
> file, it worked fine.
> Could someone can comment why I got "Segmentation fault"? Thank you for
> your help!

Your MPI setup might require you use a command like "mpirun -N 2 mdrun_mpi
..." to make it work - the segfault might be a gromacs-MPI interaction
problem. If you can run an MPI process from the command line you may get
more helpful feedback.


More information about the gromacs.org_gmx-users mailing list