[gmx-users] Replica Exchange MD Errors

David van der Spoel spoel at xray.bmc.uu.se
Wed Dec 20 20:21:24 CET 2006

Robert Johnson wrote:
> Hello everyone,
> I am trying to run some benchmakrs on a replica exchange simulation. I
> have several .tpr files: topol0.tpr, topol1.tpr, topol2.tpr, up to
> topol7.tpr. I would like the calculation to proceed all on the same
> node (for benchmarking and debugging reasons and so I don't have to
> wait in a queue). However, I am having problems launching the job.
> Here are the commands I've tried along with the corresponding error
> message:
> mpirun -np 1 mdrun_mpi -replex 160 -s topol
> ERROR: Can not open file topol.tpr
> mpirun -np 1 mdrun_mpi -replex 160 -s topol*
> ERROR: Nothing to exchange with only one replica
> I've tried other combinations and included the -multi flag, but all
> have given one of these error messages. Any suggestions?
> Thanks,
how about mpirun -np 160
you can also run that on one cpu...

David van der Spoel, PhD, Assoc. Prof., Molecular Biophysics group,
Dept. of Cell and Molecular Biology, Uppsala University.
Husargatan 3, Box 596,  	75124 Uppsala, Sweden
phone:	46 18 471 4205		fax: 46 18 511 755
spoel at xray.bmc.uu.se	spoel at gromacs.org   http://folding.bmc.uu.se

More information about the gromacs.org_gmx-users mailing list