[gmx-users] Replica Exchange MD Errors

Mark Abraham Mark.Abraham at anu.edu.au
Thu Dec 21 00:09:54 CET 2006

Robert Johnson wrote:
> Hello everyone,
> I am trying to run some benchmakrs on a replica exchange simulation. I
> have several .tpr files: topol0.tpr, topol1.tpr, topol2.tpr, up to
> topol7.tpr. I would like the calculation to proceed all on the same
> node (for benchmarking and debugging reasons and so I don't have to
> wait in a queue). However, I am having problems launching the job.
> Here are the commands I've tried along with the corresponding error
> message:
> mpirun -np 1 mdrun_mpi -replex 160 -s topol
> ERROR: Can not open file topol.tpr
> mpirun -np 1 mdrun_mpi -replex 160 -s topol*
> ERROR: Nothing to exchange with only one replica

Don't use the wildcard asterisk... but the error message is hinting at 
the real problem.

> I've tried other combinations and included the -multi flag, but all
> have given one of these error messages. Any suggestions?

You don't tell MPI to run n processes on one node and/or processor with 
the mpirun -np flag... you have to do that earlier with the setup of 
your MPI environment. Your commands above are directing the use of one 
process, which can't run REMD for GROMACS.

Further, if you'd read "man mdrun" like I suggested last time, you'd 
have noticed that an -np flag to mdrun is advisable under some 
circumstances, so you should be trying that.

Set up your MPI environment to pack 8 processes into one node, then use

mpirun -np 8 mdrun_mpi -np 8 -multi -replex 160 -s t topol


More information about the gromacs.org_gmx-users mailing list