[gmx-users] intel compiler + amd64: help needed.

Jones de Andrade johannesrs at gmail.com
Wed May 31 08:35:43 CEST 2006

Hi all.

Ok, I admit that I've posted it before. But I still not finding the
error that makes the gromacs compilation with intel compilers not work
on my AMD64 machine here.

The error I get is still the following:
./mknb   -software_invsqrt
 >>> Gromacs nonbonded kernel generator (-h for help)
 >>> Generating single precision functions in C.
 >>> Using Gromacs software version of 1/sqrt(x).
 make[5]: *** [kernel-stamp] Falha de segmentação
 make[5]: Leaving directory
 make[4]: ** [all-recursive] Erro 1

In the actual stage, I've already tried even reinstallation of the
intel compilers themselves, and it's still not working. The best clue
up to now was that I would be using a mix of 32 and 64 bits compilers
and libraries, and to assure that the compiler was 64 bits I
reinstalled it step by step this time. I do not know how to confirm
that all libraries are 64 bits, or how to point every single one to
the 64 bit version.

The issue goes way beyound the socket, compiler flags, and so on. Here
I go: I started to think that the problem could be related to the
intel X amd issue on compilers, on which the intel compiler somehow
blocks the SSE instructions on amd machines. Since the problem appears
on the famous inv-sqrt function, written on assembly and using the SSE
instruction to run faster, maybe there is a connection.

The problem is that I tried all configure related flags I found
(enable-fortran, disable-software-sqrt and disable-x86_64-sse), and
not even this is working. The computer complains about that function,
in both machines I have available, doesn't matter what combination of
configure flags I use!

So, I'm not quite sure (better say, I have no idea at all) about
what's wrong in my configure-compilation process. Could *please*
anyone who successfully compiled gromacs on an AMD64 family machine
using the intel ompiler give me some advice? Or maybe a correct
makefile, or so?

I'm following the guidelines from the website, and sending the
Makefile configure created for me. one of the infinite trials. :(  If
someone have previous knowledge of this problem from previous
experiences, please reply.

Thank you all for everything in advance!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: Makefile
Type: application/octet-stream
Size: 23246 bytes
Desc: not available
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20060531/e6c68c17/attachment.obj>

More information about the gromacs.org_gmx-users mailing list