[gmx-users] intel compiler + amd64: help needed.

David van der Spoel spoel at xray.bmc.uu.se
Wed May 31 08:47:48 CEST 2006

Jones de Andrade wrote:
> Hi all.
> Ok, I admit that I've posted it before. But I still not finding the
> error that makes the gromacs compilation with intel compilers not work
> on my AMD64 machine here.
> The error I get is still the following:
> ****************************************************************************** 
> ./mknb   -software_invsqrt
>  >>> Gromacs nonbonded kernel generator (-h for help)
>  >>> Generating single precision functions in C.
>  >>> Using Gromacs software version of 1/sqrt(x).
> make[5]: *** [kernel-stamp] Falha de segmentação
> make[5]: Leaving directory
> `/home/johannes/src/gromacs/gromacs-3.3/src/gmxlib/nonbonded/nb_kernel'
> make[4]: ** [all-recursive] Erro 1
> ***************************************************************************** 

your problem here is that the mknb program crashes with a SEGV, which is 
weird. You could try
make CFLAGS=-g mknb
./mknb -software_invsqrt
make install

Obviously if mknb crashed due to compiler bugs then you might not want 
to use that compiler anyway, but if there is a real problem in the 
program you will be able to debug it.

> In the actual stage, I've already tried even reinstallation of the
> intel compilers themselves, and it's still not working. The best clue
> up to now was that I would be using a mix of 32 and 64 bits compilers
> and libraries, and to assure that the compiler was 64 bits I
> reinstalled it step by step this time. I do not know how to confirm
> that all libraries are 64 bits, or how to point every single one to
> the 64 bit version.
> The issue goes way beyound the socket, compiler flags, and so on. Here
> I go: I started to think that the problem could be related to the
> intel X amd issue on compilers, on which the intel compiler somehow
> blocks the SSE instructions on amd machines. Since the problem appears
> on the famous inv-sqrt function, written on assembly and using the SSE
> instruction to run faster, maybe there is a connection.
> The problem is that I tried all configure related flags I found
> (enable-fortran, disable-software-sqrt and disable-x86_64-sse), and
> not even this is working. The computer complains about that function,
> in both machines I have available, doesn't matter what combination of
> configure flags I use!
> So, I'm not quite sure (better say, I have no idea at all) about
> what's wrong in my configure-compilation process. Could *please*
> anyone who successfully compiled gromacs on an AMD64 family machine
> using the intel ompiler give me some advice? Or maybe a correct
> makefile, or so?
> I'm following the guidelines from the website, and sending the
> Makefile configure created for me. one of the infinite trials. :(  If
> someone have previous knowledge of this problem from previous
> experiences, please reply.
> Thank you all for everything in advance!
> Jones
> ------------------------------------------------------------------------
> _______________________________________________
> gmx-users mailing list    gmx-users at gromacs.org
> http://www.gromacs.org/mailman/listinfo/gmx-users
> Please don't post (un)subscribe requests to the list. Use the 
> www interface or send it to gmx-users-request at gromacs.org.
> Can't post? Read http://www.gromacs.org/mailing_lists/users.php

David van der Spoel, PhD, Assoc. Prof., Molecular Biophysics group,
Dept. of Cell and Molecular Biology, Uppsala University.
Husargatan 3, Box 596,  	75124 Uppsala, Sweden
phone:	46 18 471 4205		fax: 46 18 511 755
spoel at xray.bmc.uu.se	spoel at gromacs.org   http://folding.bmc.uu.se

More information about the gromacs.org_gmx-users mailing list