[gmx-users] how to submit replica exchange MD simulation

N-J.M. Macaluso njmm2 at cam.ac.uk
Mon Apr 9 13:20:09 CEST 2007


    I have a question regarding replica exchange MD in Gromacs. I think I 
am preparing all of the files in the correct fashion, but I continually get 
the same error message.
    Here is what I'm doing. I prepared three different mdp files, each 
specifying a specific temperature (PME0.mdp, PME1.mdp, and PME2.mdp). Then 
I grompp the energy minimized peptide I want to simulate:

grompp -f PME0.mdp -po PME0out.mdp -c peptide.gro -p peptide.top -o 
peptide0.tpr -np 4

grompp -f PME1.mdp -po PME1out.mdp -c peptide.gro -p peptide.top -o 
peptide1.tpr -np 4

grompp -f PME2.mdp -po PME2out.mdp -c peptide.gro -p peptide.top -o 
peptide2.tpr -np 4

After this, I submit the simulation via an MPI queueing system. The mdrun 
command looks like this:

mdrun_mpi -replex 1000 -s peptide.tpr -np 4 -o peptide.trr -c 
peptide_remd.gro -g peptide_remd.log -e peptide_remd.edr

After I submit mdrun to our cluster, I find the gromacs.e message gives me 
this error:

"run input file peptide0.tpr was made for 4 nodes, while mdrun_mpi expected 
it to be for 1 node."

It would seem as though I'm doing something wrong in specifying the number 
of nodes in the mpi file, but I've checked this over several times and I 
can't find anything in the mpi file to suggest that it's expecting one 
node. Furthermore, I tried running the simulation without the "replex" 
command, and everthing worked just fine for a normal md run at one 
temperature with the same mdrun_mpi file.
     Do you have any suggestions as to what is going wrong? Am I submitting 
the REMD commands correctly?


Max Macaluso

More information about the gromacs.org_gmx-users mailing list