[gmx-users] how to submit replica exchange MD simulation

N-J.M. Macaluso njmm2 at cam.ac.uk
Thu Apr 12 15:01:19 CEST 2007

    Thank you for your response. I have another question regarding the 
implementation of replica exchange in Gromacs. In order to run such a 
simulation on version 3.3 I need to install the LAM/MPI version of Gromacs 
and load the appropriate modules on the cluster (at the moment we use 
score). If I install the latest CVS version ( 3.399), is it possible to run 
replica exchange in an score environment, or do I still need LAM? Also, is 
REMD implemented differently in the CVS version?
Max Macaluso

On Apr 9 2007, David van der Spoel wrote:

>N-J.M. Macaluso wrote:
>> Hello,
>>    I have a question regarding replica exchange MD in Gromacs. I think I 
>> am preparing all of the files in the correct fashion, but I continually 
>> get the same error message.
>>    Here is what I'm doing. I prepared three different mdp files, each 
>> specifying a specific temperature (PME0.mdp, PME1.mdp, and PME2.mdp). 
>> Then I grompp the energy minimized peptide I want to simulate:
>> grompp -f PME0.mdp -po PME0out.mdp -c peptide.gro -p peptide.top -o 
>> peptide0.tpr -np 4
>you can only run each replica on one processor in 3.3
>> After this, I submit the simulation via an MPI queueing system. The 
>> mdrun command looks like this:
>> mdrun_mpi -replex 1000 -s peptide.tpr -np 4 -o peptide.trr -c 
>> peptide_remd.gro -g peptide_remd.log -e peptide_remd.edr
>you probably need to use mpirun here:
>mpirun -c 4 mdrun etc.
>> After I submit mdrun to our cluster, I find the gromacs.e message gives 
>> me this error:
>> "run input file peptide0.tpr was made for 4 nodes, while mdrun_mpi 
>> expected it to be for 1 node."
>> It would seem as though I'm doing something wrong in specifying the 
>> number of nodes in the mpi file, but I've checked this over several 
>> times and I can't find anything in the mpi file to suggest that it's 
>> expecting one node. Furthermore, I tried running the simulation without 
>> the "replex" command, and everthing worked just fine for a normal md run 
>> at one temperature with the same mdrun_mpi file.
>>     Do you have any suggestions as to what is going wrong? Am I 
>> submitting the REMD commands correctly?
>> Thanks,
>> Max Macaluso
>> _______________________________________________ gmx-users mailing list 
>> gmx-users at gromacs.org http://www.gromacs.org/mailman/listinfo/gmx-users 
>> Please search the archive at http://www.gromacs.org/search before 
>> posting! Please don't post (un)subscribe requests to the list. Use the 
>> www interface or send it to gmx-users-request at gromacs.org. Can't post? 
>> Read http://www.gromacs.org/mailing_lists/users.php

More information about the gromacs.org_gmx-users mailing list