[gmx-users] Failed Energy Minimization

Mark Abraham Mark.Abraham at anu.edu.au
Fri Apr 20 02:19:31 CEST 2007

Justin M. Shorb wrote:
> Greetings:
> I have been having trouble running any energy minimization with any sort 
> of system. I have small polypeptides in water, and then large proteins 
> in water with the same error message:

> No matter what run parameters I get, I always get ci = -2147483648. Even 
> different systems. (This, I realize is simply numerically infinity). If 
> I try running with ns_type = simple, the em runs until it hits around 35 
> and then says it didn't converge. Since I am running grompp_d -v, I get 
> that there are certain atoms that have infinite potential. But, 
> depending on the system, the atom type (solvent or molecule) changes.

This suggests a problem with your force field and/or topology.

> I have noted that previous posts have been answered with an admonition: 
> "Find out which atoms are infinite force, and then fix it." I suppose I 
> could go through, find the atoms and remove those waters that overlap, 
> but shouldn't this be taken into account by the genbox_d program? I also 
> have tried to increase the vdw radii in the vdwradii.dat file to have it 
> delete more waters. But, even after having 60 fewer waters around a 88 
> kD protein, the system still fails to energy minimize.

This suggests that the source of the problem isn't that these atoms 
start life too close together, but maybe they're moving too close 
together because of some other problem? (Unless the error is always 
happening before the first EM step)

> Given that this seems to be a common problem in solvating a system, are 
> there better options (options for genbox??) than running the following 
> shell commands? The em.mdp file is also shown below.

That all seems fine.


More information about the gromacs.org_gmx-users mailing list