[gmx-users] Re: Install problem

John Mercer jmercer at duke.edu
Tue Aug 14 21:06:29 CEST 2007

My thnaks to all those who responed with suggestions on the install  

In order:

1. David van der Spoel

Indeed using the c-shell fixes the problem completely

2. Ibrahim

An interesting idea using GMXBIN, but since using the c-shell fixed  
my problem, it feels more natural just to keep that fix.

3. bharat

I did remove items from PATH until it was ~500 bytes.  Then it  
worked.  I thought the problem was solved but then found that I  
inherited another curious problem which is that for deep working  
directories the problem came back.  By that I mean, if I have a  
nested set of directories, I don't have PATH problems but once I  
reach a certain depth, it comes back again.  So I went with the c- 
shell solution.

4. Erik

I suspect that your explanation gives the best the reason why I have  
the PATH problem.  I came to believe after some experimentation, that  
it had to do with how the code handles PATH, because even with a long  
path it still executes but has a segmentation fault.  In any case  
when I do another install I will try your approach and see if I can  
get it to work in the bash shell since that is now the mac default,  
but in the meantime I am anxious to learn about the use of the  
program--and it works in the c-shell.

Again thanks to all.


On Jul 19, 2007, at 5:30 AM, Erik Lindahl wrote:

> Hi,
> On Jul 19, 2007, at 12:52 AM, Ibrahim M. Moustafa wrote:
>> Hi Jhon,
>>    I have the same issue with GROMACS on Mac PPC 10.4.
>> The program executes only with the full path specified. I posted a  
>> similar question
>> before, you can check the archive, but got no solution for the  
>> problem.
>> What I did is that I aliased all modules in GMXBIN to the full  
>> path and it works fine with me.
>>   If you find another solution for the problem, I'd love to know.
> When Gromacs is installed, the location specified with --prefix= on  
> the configure line is compiled into the program.
> At runtime, we do the following to find library files:
> 1. First we look in the current directory for files
> 2. Then, If the GMXLIB variable is set, we look there.
> 3. Failing that, we check in the default install location compiled-in.
> 4. Finally, if nothing else works, we try to find the full path to  
> the binary you executed (either it's in the path variable, or you  
> gave a full path when running), and look in the same tree for a  
> gromacs installation.
> Thus, if you used fink to install but Gromacs can't find the  
> libraries my first bet would be that --prefix wasn't set correctly  
> during compile.
> Cheers,
> Erik
> _______________________________________________
> gmx-users mailing list    gmx-users at gromacs.org
> http://www.gromacs.org/mailman/listinfo/gmx-users
> Please search the archive at http://www.gromacs.org/search before  
> posting!
> Please don't post (un)subscribe requests to the list. Use thewww  
> interface or send it to gmx-users-request at gromacs.org.
> Can't post? Read http://www.gromacs.org/mailing_lists/users.php

More information about the gromacs.org_gmx-users mailing list