[gmx-users] ci variable range error in parallel but NOT in serial

dtmirij dtmirij at sandia.gov
Mon May 14 21:24:26 CEST 2007

Hello everyone,

I am running starting from a minimized/equilibrated structure.
When I run the the system with my serial built executable, it runs fine and
the energies and pressures look fine.

When I run the exact same system from the same starting conditions using my
serial built executable on two processors, I get the following error after
running for over a half million timesteps:

Grid: 9 x 11 x 14 cells
Program mdrun_d_p, VERSION 3.3.1
Source code file: nsgrid.c, line: 226

Range checking error:
Explanation: During neighborsearching, we assign each particle to a grid
based on its coordinates. If your system contains collisions or parameter
errors that give particles very high velocities you might end up with some
coordinates being +-Infinity or NaN (not-a-number). Obviously, we cannot
put these on a grid, so this is usually where we detect those errors.
Make sure your system is properly energy-minimized and that the potential
energy seems reasonable before trying again.

Variable ci has value 1434. It should have been within [ 0 .. 1386 ]
Please report this to the mailing list (gmx-users at gromacs.org)

When I plot the energies and pressures of what was completed by the parallel
run before crashing, they are in line with those from the serial run, and
there seems to be nothing out of the ordinary.

I have seen this problem previously posted in the archives, however I did
not find a posted solution to the problem.

Does anyone have an idea what is going on and how to remedy the problem?

How is the ci variable range determined?  Can it manually be set to a larger

Thank you.

More information about the gromacs.org_gmx-users mailing list