[gmx-users] gromacs installation in IBM BLUEGENE

Anupam Nath Jha anupam at mbu.iisc.ernet.in
Wed Nov 28 08:52:19 CET 2007

Dear all

I've tried compiling both version 3.3.1 and 3.3.2 of GROMACS on an IBM Blue
Gene/L system but get the same error message with each version.

To compile the GROMACS I've used the following settings/configure flags:

./configure                                                                \
  --enable-mpi                                                                  \
  --enable-float                                                                \
  --program-suffix=_mpi                                                         \
  --prefix=/home/phd/04/mbuanjha/soft/gmx332                                    \
  --enable-type-prefix                                                          \
  --enable-all-static                                                           \
  --disable-nice                                                                \
  --disable-shared                                                              \
  --disable-threads                                                             \
  --without-motif                                                               \
  --without-x                                                                   \
  --without-malloc                                                              \
  --with-fft=fftw3                                                              \
  --enable-ppc-altivec                                                          \
  --build=i686-linux-gnu                                                        \
  --host=powerpc                                                                \
        CC=/bgl/BlueLight/ppcfloor/bglsys/bin/mpixlc                            \
       F77=/bgl/BlueLight/ppcfloor/bglsys/bin/mpixlf77                          \
       CXX=/bgl/BlueLight/ppcfloor/bglsys/bin/mpixlcxx                          \
     MPICC=/bgl/BlueLight/ppcfloor/bglsys/bin/mpixlc                            \
    CFLAGS="-O3 -qarch=440d -qtune=440 -qhot"                                   \
    FFLAGS="-O3 -qarch=440d -qtune=440 -qhot"                                   \
  CXXFLAGS="-O3 -qarch=440d -qtune=440 -qhot"                                   \
-L/home/phd/04/mbuanjha/soft/MYINC"                \
-I/home/phd/04/mbuanjha/soft/MYINC"              \
      LIBS="-lmpich.rts -lmsglayer.rts -lrts.rts -ldevices.rts -lcxxmpich.rts

at the time of running this, i got few warning, as:

configure:26419: WARNING: Couldn't find XDR headers and/or libraries - using our
configure:26428: checking for working memcmp
configure:26517: result: no

but when i make mdrun, it gives error:

(cd ./src/gmxlib && make ; exit 0)
make[1]: Entering directory `/home/phd/04/mbuanjha/soft/gromacs-3.3.2/src/gmxlib'
Making all in nonbonded
make[2]: Entering directory
Making all in nb_kernel
make[3]: Entering directory
rm -f kernel-stamp
./mknb   -software_invsqrt
>>> Gromacs nonbonded kernel generator (-h for help)
>>> Generating single precision functions in C.
>>> Using Gromacs software version of 1/sqrt(x).
Error: Cannot open nb_kernel010_c.c for writing.
make[3]: *** [kernel-stamp] Error 1
make[3]: Leaving directory
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/phd/04/mbuanjha/soft/gromacs-3.3.2/src/gmxlib'
(cd ./src/mdlib && make ; exit 0)
make[1]: Entering directory `/home/phd/04/mbuanjha/soft/gromacs-3.3.2/src/mdlib'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/phd/04/mbuanjha/soft/gromacs-3.3.2/src/mdlib'
(cd ./src/kernel && make mdrun ; exit 0)
make[1]: Entering directory `/home/phd/04/mbuanjha/soft/gromacs-3.3.2/src/kernel'
make[1]: *** No rule to make target `../gmxlib/libgmx_mpi.la', needed by
`mdrun'.  Stop.
make[1]: Leaving directory `/home/phd/04/mbuanjha/soft/gromacs-3.3.2/src/kernel'

and stops.

thanks in advance

Science is facts; just as houses are made of stone, so is science is made of
facts; but a pile of stones is not a house, and  a collection of facts is not
necessarily science.

Anupam Nath Jha
Ph. D. Student
Saraswathi Vishveshwara Lab
Molecular Biophysics Unit
Ph. no.-22932611

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the gromacs.org_gmx-users mailing list