[gmx-users] stuck

Adam Fraser adam.n.fraser at gmail.com
Fri Oct 12 17:51:44 CEST 2007


I'm trying to get started working with a system of 2 hexadecane molecules in
water but I'm having some trouble.

I'm getting the following error when I run:
  grompp -f simulate.mdp -c 2Hex_solv.gro -p 2Hex.top -o md.tpr

Program grompp, VERSION 3.3.2
Source code file: readir.c, line: 794

Fatal error:
Group protein not found in indexfile.
Maybe you have non-default goups in your mdp file, while not using the '-n'
option of grompp.
In that case use the '-n' option.

So I built an .ndx file with make_ndx and passed it to grompp with -n and it
still doesn't work.

Up until this point I've done the following:

// convert pdb to gro
editconf -f 2Hex.pdb -o 2Hex.gro

// create topology file from .gro
x2top -f 2Hex.gro -o 2Hex.top

   // build hexadecane.itp and include it in HexA.top  (seems unneccessary)
   #include "hexadecane.itp"

// create md input
grompp -f minim.mdp -c 2Hex.gro -p 2Hex.top -o input.tpr

// minimize structure
mdrun -v -s input.tpr -o 2Hex_min.trr -c 2Hex_min.gro

// set up box
editconf -f 2Hex_min.gro -o 2Hex_min_box.gro -d 0.75 -bt cubic

// solvate
genbox -cp 2Hex_min_box.gro -cs spc216.gro -o 2Hex_solv.gro -p HexA.top

   #include "spc.itp"  (in HexA.top)

// finally attempting to build md input file
grompp -f simulate.mdp -c 2Hex_solv.gro -p 2Hex.top -o md.tpr

Any ideas what I might be doing wrong?

Thanks much,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20071012/3c0d591a/attachment.html>

More information about the gromacs.org_gmx-users mailing list