[gmx-users] stuck

Mark Abraham Mark.Abraham at anu.edu.au
Sat Oct 13 02:55:23 CEST 2007

Adam Fraser wrote:
> Hello,
> I'm trying to get started working with a system of 2 hexadecane 
> molecules in water but I'm having some trouble.
> I'm getting the following error when I run:
>   grompp -f simulate.mdp -c 2Hex_solv.gro -p 2Hex.top -o md.tpr
> Program grompp, VERSION 3.3.2
> Source code file: readir.c, line: 794
> Fatal error:
> Group protein not found in indexfile.
> Maybe you have non-default goups in your mdp file, while not using the 
> '-n' option of grompp.
> In that case use the '-n' option.

If you don't supply an index file, grompp has some pre-defined groups. 
I'm guessing they're case sensitive, though, so you should be using 
"Protein", etc.

> So I built an .ndx file with make_ndx and passed it to grompp with -n 
> and it still doesn't work.

Not very helpful. "Doesn't work" embraces a myriad of possibilities.

> Up until this point I've done the following:
> // convert pdb to gro
> editconf -f 2Hex.pdb -o 2Hex.gro
> // create topology file from .gro
> x2top -f 2Hex.gro -o 2Hex.top
>    // build hexadecane.itp and include it in HexA.top  (seems unneccessary)
>    #include "hexadecane.itp"

See http://wiki.gromacs.org/index.php/topology_file

> // create md input
> grompp -f minim.mdp -c 2Hex.gro -p 2Hex.top -o input.tpr
> // minimize structure
> mdrun -v -s input.tpr -o 2Hex_min.trr -c 2Hex_min.gro
> // set up box
> editconf -f 2Hex_min.gro -o 2Hex_min_box.gro -d 0.75 -bt cubic
> // solvate
> genbox -cp 2Hex_min_box.gro -cs spc216.gro -o 2Hex_solv.gro -p HexA.top
>    #include "spc.itp"  (in HexA.top)
> // finally attempting to build md input file
> grompp -f simulate.mdp -c 2Hex_solv.gro -p 2Hex.top -o md.tpr
> Any ideas what I might be doing wrong?


More information about the gromacs.org_gmx-users mailing list