[gmx-users] help with gromacs install in opensuse 64b

Diego Enry diego.enry at gmail.com
Sun Apr 27 23:59:20 CEST 2008

On Sun, Apr 27, 2008 at 6:49 PM, fabracht sdf <fabracht at gmail.com> wrote:
> I am trying to install gromacs on opensuse 10. I've compiled fftw lybraries
> every possible way i could, but every time i try to install gromacs, i mean,
> every time i run ./configure --enable-mpi i get the same error. I have tryed
> to find the solution to this in the grmx mailing lists but couldn't find the
> exact same error or a solution that suited me. Maybe I should look some
> more, but i someone could give me a help that would be really good. Here is
> the error line the ./configure generates.

did you compile & installed as root ?

I usually get this "checking for main in -lfftw3f... no" when I forget
to compile FFTW with single precision. Try this for fftw:

# single
make distclean
./configure --enable-float --enable-sse --enable-threads --enable-type-prefix
make install

# double
make distclean
./configure --enable-sse2 --enable-threads --enable-type-prefix
make install

>  ...
> checking for fftw3.h... yes
> checking for main in -lfftw3f... no
> configure: error: Cannot find fftw3f library
> bracht at linux-2ygp:~/Download/gromacs-3.3.2>
> Thank you in advance.
> Fabrício Bracht
> _______________________________________________
>  gmx-users mailing list    gmx-users at gromacs.org
>  http://www.gromacs.org/mailman/listinfo/gmx-users
>  Please search the archive at http://www.gromacs.org/search before posting!
>  Please don't post (un)subscribe requests to the list. Use the
>  www interface or send it to gmx-users-request at gromacs.org.
>  Can't post? Read http://www.gromacs.org/mailing_lists/users.php

Diego Enry B. Gomes
Laboratório de Modelagem e Dinamica Molecular
Universidade Federal do Rio de Janeiro - Brasil.

More information about the gromacs.org_gmx-users mailing list