[gmx-users] [gmx-developers] double precision, gmx-3.3.1 and 3.3.2 do not work for me

David.Osguthorpe at UCHSC.edu David.Osguthorpe at UCHSC.edu
Tue Jan 22 20:46:55 CET 2008


Sorry for the delay but Im having problems with sending email to this list - some spam filters must be at work.

I think Ive had the same problem - at least the symptoms were the same - a running single precision dataset
when supplied to a double precision program gave instant infinite forces as shown
- more specifically for me the LJ-14 and Coul-14 were the ones which gave rise to the problem having stupidly
high energies.

However, I had another double precision version on another machine and when I tried there it worked.

So it was obviously the build - Id copied the double precision source from a single precision  compile.

I redid the build with two important steps

make clean


make distclean

re-did the configure using the configure from the other machine ( but as far as I could it was the same as the
current machine)

and the program now works.

I dont really know what happened and why the new build works but Im suspicous of the make distclean - I could
well have not done that previously.

There was the issue of a system upgrade around this time which updated the gcc version.


PS this is probably html email - because of the spam issues Im having to run this using crappy webmail.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20080122/16fa26cf/attachment.html>

More information about the gromacs.org_gmx-users mailing list