[gmx-users] Cannot link gmx4.0.1 to openmpi

Martin Höfling martin.hoefling at gmx.de
Tue Oct 21 17:05:49 CEST 2008

Am Dienstag 21 Oktober 2008 16:38:22 schrieb rversace at ccny.cuny.edu:

> After I compiled and installed the update gmx4.0.1 using the cvs. I get the
> following message when i tried to link it with openmpi:
> configure: error: Cannot compile and link MPI code with mpicc
> mpicc: error while loading shared libraries: libimf.so: cannot open shared
> object file: No such file or directory
> It is strange because with the previous version, everything went fine. Did
> anyone have the same problem? Thank you.

Similar but not the same:

I got this "not found" error during runtime, when using intel-mpi and intel 
For me, adding "-static-intel" to the CFLAGS solved the issue.

Since you're failing during the linking step, you should check if libimf.so is 
in your linker path and if you wanna link dynamically also during runtime. 

I would suggest specifying the libimf.a path in LDFLAGS and then link intel 
libraries statically.


More information about the gromacs.org_gmx-users mailing list