[gmx-users] A MPI librabry not recognized by the configure script

Nicolas Sapay nsapay at ucalgary.ca
Fri Sep 5 20:50:27 CEST 2008


I'm trying to compile the Gromacs-3.3.3 package with MPI and have the 
following issue when I run the configuration script:

    ./configure --prefix /home/users/nsapay/local/bin/gromacs-3.3.3
    --program-suffix _mpi --enable-mpi --disable-nice MPICC=mpicc CC=gcc
     >>> checking size of int... configure: error: cannot compute sizeof

the config.log file tells me it's because a MPI library is not found:

    configure:7621: mpicc -o conftest  -O3 -fomit-frame-pointer
    -finline-functions -Wall -Wno-unused -funroll-all-loops
    -L/home/users/nsapay/local/bin/fftw-3.1.2/lib/  conftest.c  >&5
    configure:7624: $? = 0
    configure:7630: ./conftest
    ./conftest: error while loading shared libraries: libmpio.so.1:
    cannot open shared object file: No such file or directory
    configure:7633: $? = 127
    configure: program exited with status 127

I tried to reconfigure the installation by including the directory where 
the libmpi is stored:

    ./configure --prefix /home/users/nsapay/local/bin/gromacs-3.3.3
    --program-suffix _mpi --enable-mpi --disable-nice MPICC=mpicc
    CC=gcc  --without-x 

But it doesn't work. I get exactly the same error message. Why the 
libmpio.so.1 library is not recognized by the configuration script? Note 
that I have compiled Gromacs without MPI with no particular issue.  The 
system is a HP cluster with AMD processors, Red Hat 4.5, gcc/mpicc 3.4.6.

Thanks a lot for your advices

-------------- next part --------------
A non-text attachment was scrubbed...
Name: nsapay.vcf
Type: text/x-vcard
Size: 282 bytes
Desc: not available
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20080905/72dab2a4/attachment.vcf>

More information about the gromacs.org_gmx-users mailing list