[gmx-users] Re: gmx-users] Mopac7 / Gromacs 4.0.4 Issue

Gerrit Groenhof ggroenh at gwdg.de
Thu Apr 9 08:45:29 CEST 2009


it should suffice to set the LIBS prior to compiling.

With what compiler was mopac7 compiled? 

I have thus far only been able to compile a working version with f2c/gcc.

Not optimal. Using the intel fortran compiler, I also get a running mopac, but the results are not correct and I don't know why.

Anyway, after creating the library, I set LIBS '-lmopac -lf2c -lm', and configure creates working makefiles.

Hope this helps.


Message: 3
Date: Wed, 8 Apr 2009 16:24:34 -0700
From: Matthew Lardy <lardy.ma at gmail.com>
Subject: [gmx-users] Mopac7 / Gromacs 4.0.4 Issues
To: gmx-users at gromacs.org
	<12741c010904081624s46a146d3kbf3519f600594f2e at mail.gmail.com>
Content-Type: text/plain; charset="iso-8859-1"

 Hi all,
I have been playing with Mopac7 (both version 7 and the more recent Mopac
7-1.10 release).  I have compiled both Mopac and
Gromacs independently without issue.  But when I try to add -with-qmmm-mopac
to my ./configure line, I am unable to compile and link them together.

I have been looking at this for some time, and I have read the posts to this
list.  I have two issues that I think may be related.

First, when I add the -lmopac to the LIBS environment variable, -DUSE_MOPAC
to CPPFLAGS and -L/(Path to Mopac Libs) to LDFLAGS, I don't make it out of
the configure alive:

from config.log
ld: -lmopac

So, I added the lmopac information in to pkgconfig...  Once again no dice
with ./configure.    So I then reset my environment and stepped through the
configure.  Now after removing the references to mopac in my environment,
run the ./configure as I have done so previously, and then add the mopac
environment variables by hand, I get the following errors:

icc -O3 -tpp6 -axK -ip -w -funroll-all-loops -o grompp grompp.o
 -L/path/to/fftw-3.2.optim-thread/lib -L/vscrn/Packages/MopacOpt/lib
./.libs/libgmxpreprocess.a ../mdlib/.libs/libmd.a
/path/to/gromacs-4.0.4/src/gmxlib/.libs/libgmx.a ../gmxlib/.libs/libgmx.a
-lnsl /path/to/fftw-3.2.optim-thread/lib/libfftw3f.a -lm -lmopac
/path/to/MopacOpt/lib/libmopac.a(lread.o)(.text+0x160): In function
: undefined reference to `__ctype_b'
/path/to/MopacOpt/lib/libmopac.a(lread.o)(.text+0x21f): In function
: undefined reference to `__ctype_b'
/path/to/MopacOpt/lib/libmopac.a(lread.o)(.text+0x296): In function
: undefined reference to `__ctype_b'
/path/to/MopacOpt/lib/libmopac.a(lread.o)(.text+0x2d0): In function
: undefined reference to `__ctype_b'
/path/to/MopacOpt/lib/libmopac.a(lread.o)(.text+0x8b2): In function
: undefined reference to `__ctype_b'
/path/to/MopacOpt/lib/libmopac.a(lread.o)(.text+0xb05): more undefined
references to `__ctype_b' follow
make[3]: *** [grompp] Error 1
make[3]: Leaving directory `/path/to/gromacs-4.0.4/src/kernel'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/path/to/gromacs-4.0.4/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/path/to/gromacs-4.0.4/src'
make: *** [all-recursive] Error 1

I should add that I have downloaded and used Gerrit's mopac library, as well
as patched a clean version of Mopac7.  No dice.  Oh yeah, I have tried the
GNU compilers as well.  And, cleaned the application every time I have tried
to rebuild.

I figure that there is something simple that I have forgotten.

Thanks in advance!

More information about the gromacs.org_gmx-users mailing list