[gmx-users] pre-compiled MacOS 3.3.2 gmx_sumi error

Mark Abraham Mark.Abraham at anu.edu.au
Fri Feb 20 22:31:41 CET 2009

Dean Cuebas wrote:
> Dear users,
> I have the precompiled macosx 3.3.2 package, and I’m getting the 
> following error during a PR mdrun:
> -------------------------------------------------------
> Program mdrun, VERSION 3.3.2
> Source code file: network.c, line: 437
> Routine should not have been called:
> gmx_sumi
> -------------------------------------------------------
> I see in the list archives that there is a bug in 3.3.2 that makes this 
> happen.
> Can I fix this?  Or do I need to compile a newer version (that is 
> supposedly fixed) in order to do any work?

It's always worth using either the version for which the tutorial was 
prepared, or the latest version with the same major version number, 
since these are most likely to work correctly.

> Also, the pre equilibration steps of the protein and protein in 
> water/salt do not converge to anything near
> Fmax<1, which is what was stated in the tutorial that I am doing.

I can't see that in Kerrigan's drug-enzyme tutorial.

> Isn’t the MacOSX precompiled binary only single precision, and what the 
> heck good is that if nothing can converge??????

Single precision is correct for routine gromacs usage.

> Can someone please help me decide on a gmx package to install that will 
> actually work so I can get through a single tutorial.

As above, use one for which the tutorial is prepared. On the top of the 
tutorial it lists the version for which it was prepared. I've just 
gotten as far as a successful EM using 3.3.1 in about 15 minutes.

> (Sorry, but I’ve tried the drug/protein tutorial (trypsin) listed on the 
> gromacs beginners site and that was a complete nightmare because it was 
> so old.

Worked perfectly for me (apart from genbox generating a different number 
of water molecules, which I haven't bothered to look into). Whatever 
issue you were having was generated either by your interpretation and/or 
execution of the instructions, or your use of a different GROMACS version.

> Then I finally decided to try the molecular modeling practical at 
> http://nmr.chem.uu.nl/~tsjerk/course/molmod/md.html after finding that 
> is was made Dec of 2008 and would therefore be “current”, but 
> unfortunately they used gmx 3.3.1 which does NOT have the bug I 
> described above... dead in the water again!)
> Sorry for the rant, but I would love to sent down the right direction, 
> so I can get some real work done.

You're on the right track, but I can only suppose you're making mistakes 
(cf earlier thread about number of atoms). It's rather more probable 
that a user new to GROMACS is doing so, than the person who wrote the 
tutorial made some egregious error.


More information about the gromacs.org_gmx-users mailing list