[gmx-users] Installation with non standard location of fftw3

Graham Kettlewell grahamk at uow.edu.au
Tue Jun 30 03:55:09 CEST 2009


I have to install gromacs on a 30 node cluster computer. I only have access to a specific space on the cluster, and it didn't have fftw3 installed on it. I have installed it, and set the CPPFLAGS and LDFLAGS environment variables as per instructions. The include and lib directories exist, and the environment variables are correct.

When I tried to install without fftw3 installed I got the following:

checking for fftw3.h... configure: error: Cannot find the default external FFT library (fftw3).
Other alternatives are 'fftw2', or 'mkl' for Intel MKL.
You are STRONGLY recommended to use one of these - fftw is free.

Use CPPFLAGS and LDFLAGS if the library is installed in a
non-standard location. (see FAQ at http://www.gromacs.org)

Now with the environment variables set I get: 

checking for fftw3.h... yes
checking for main in -lfftw3f... no
configure: error: Cannot find fftw3f library

fftw3 is installed in /hpc/software/packages/chemistry/fftw

The export commands are:

-sh-3.2$ export CPPFLAGS=-I/hpc/software/packages/chemistry/fftw/include
-sh-3.2$ export LDFLAGS=-I/hpc/software/packages/chemistry/fftw/lib

as per installation documentation:

* GROMACS tries to find FFTW and all optional libraries (like Lesstif and FFTW)
automatically, but this requires that they are present in the default places where the
system searches for include files and libraries. If this is not the case (for instance,
your system might not look in /usr/local/include and /usr/local/lib where FFTW is
placed) you can tell configure to include these catalogues by using the variables
CPPFLAGS and LDFLAGS for includes and libraries, respectively.
For instance, assume we have installed FFTW with --prefix=/home/joe/fftw.


or, if you are using a bash shell:
* export CPPFLAGS=-I/home/joe/fftw/include
  export LDFLAGS=-L/home/joe/fftw/lib

Both of these directories exist, and the fftw install seemed to run without errors.

Any help would be greatly appreciated, as I am running out of ideas. I have tried to find the faq page, but without success.



Graham Kettlewell
Research assistant
Centre for Atmospheric Chemistry
University of Wollongong
grahamk at uow.edu.au
Tel: (61 2) 4221 5120
Fax: (61 2) 4221 4287
Mob: 0414 309 524

More information about the gromacs.org_gmx-users mailing list