[gmx-users] Normal Mode Analysis

Franzi Hoffgaard f.hoffgaard at gmail.com
Tue May 26 10:53:32 CEST 2009


I'm quite a new user of gromacs. I want to do an all-atom normal mode
analysis of a small protein in water. As a result I would like to have the
hessian matrix in a readable format, that I can use for further

As I have read in the manuals/tutorials/mailing-lists I minimized the whole
system (at first with the steepest descent integrator for a couple of steps
and later on with the l-bfgs integrator to become a maximum force close to
zero). Afterwards I created the run input file (with the nm integrator)
using the high precision trajectory from the minimization. This and the
following call of mdrun worked fine. As a result I became the hessian.mtx.

As I said I want the matrix in ASCII format, so I followed the instructions
and renamed the file into hessian.trj and ran "gmxdump_d -f mat2.trj" and
got a Segmentation fault.Trying gmxcheck also led to Segmentation fault. I
tried same procedure but using trr instead of trj as file-ending. Both, for
gmxcheck and gmxdump I yielded the following message:

trn version: VERSION 4.0.4
Program gmxdump_d, VERSION 4.0.4
Source code file: trnio.c, line: 69

Fatal error:
Float size 3556. Maybe different CPU?

I tried "g_traj -ox" as well without any result. This led me to the
conclusion that the file is corrupt, but I just tried diagonalizing the
hessian matrix using "g_nmeig" anyway. Surprisingly this yielded no error
message and I ended up with the first 50 eigenvalues and -vectors. So
despite my first assumption the file cannot be corrupt. Or am I wrong?

The architecture/s I worked on are:
1. Suse Linux 10.3, 64 bit, Intel Processor, quad-core (gromacs 4.0.3)
2. Mac OS X 10.5 (Leopard), Intel Proc. 2 x quad-core (gromacs 4.0.4,
gromacs 4.0.5)

The results were on both architectures the same. But ...

I read in a former email of this mailing list of a similar problem and that
the problem did not occur in the gromacs version 3.2.1. So I uninstalled
gromacs 4.0 and installed gromacs 3.2.1 and  performed the last stage of
minimization and the computation of the hessian matrix. This binary file
yielded no error using gmxdump and gmxcheck. (Input files for the l-bfgs and
nm step were not changed.)

So, my question is, is this a bug of the newer gromacs version/s or did I
something wrong. As I would like to stick to a newer version of gromacs, I
am wondering, what else (than downgrading) can I do to get the hessian
matrix in a human readable format out of the normal mode analysis.

Best regards, Franziska

Franziska Hoffgaard
PhD Student
Bioinformatics & Theo. Biology Group
TU Darmstadt
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20090526/fa3418c5/attachment.html>

More information about the gromacs.org_gmx-users mailing list