[gmx-users] Can not determine precision of trn file

Mark Abraham Mark.Abraham at anu.edu.au
Mon Nov 23 23:57:36 CET 2009

Yi Peng wrote:
> Hi, everyone,
> I was using Gromacs-4.0.3 to run my MD calculations parallell on our 
> High performance clusters for a large system which was crashed because I 
> run out the time limits. So I tried to resume my calculations by the 
> script as follows:
> mdrun -multi 16 -s md.tpr -f md.trr -e md.edr -o md.trr -g md.log -c 
> md.gro  -cpi state.cpt -append
> This worked well and give me the new .trr .edr .log files.
> But after I finished the resumed MD calculations, I tried to use 
> g_rms or gmxcheck to analyze my trajectory .trr file and got the error.
> gmxcheck -f md.trr
> The error is as follows:
> trn version: GMX_trn_file (single precision)
> Reading frame       0 time    0.000
> # Atoms  426618
> Reading frame     400 time  400.000
> -------------------------------------------------------
> Program gmxcheck, VERSION 4.0.3
> Source code file: trnio.c, line: 66
> File input/output error:
> Can not determine precision of trn file
> -------------------------------------------------------
> I just wonder how can I solve this problem. I check the previous log 
> file and found the previous crashed calculation
> "Received the TERM signal, stopping at the next step
> 241400      482.80002        0.00000
>    Energies (kJ/mol)
>        G96Angle    Proper Dih.  Improper Dih.          LJ-14     Coulomb-14
>     3.05829e+04    1.41875e+04    9.45860e+03    5.60788e+03    2.27543e+05
>         LJ (SR)        LJ (LR)   Coulomb (SR)   Coul. recip.      Potential
>     1.14629e+06   -1.99329e+04   -7.15141e+06   -8.30847e+05   -6.56851e+06
>     Kinetic En.   Total Energy    Temperature Pressure (bar)  Cons. rmsd ()
>     1.06339e+06   -5.50513e+06    2.99863e+02    1.54702e+01    2.08607e-05
> Received the TERM signal, stopping at the next step
> 241500      483.00003        0.00000"
> I checked the new log file and found the resumed calculations started 
> from 241500. So what's wrong with the resumed calculations?

Nothing, apparently. The resumption is independent of the .trr file.

> I have read many discussions about the broken trr files. Most of people 
> suggest to restart the calculations. But I am afraid of that I will get 
> the same thing out if I use the same checkpoint file. I am looking 
> forward to hearing from you.

Probably the output to the .trr file was being buffered and this wasn't 
flushed properly upon the first exit. You may even find the file is of 
zero length.

You should use the -maxh option to mdrun to avoid this issue and exit 
cleanly. You should also do small-scale tests for correct function 
before long runs that might be costly to replace :-)


More information about the gromacs.org_gmx-users mailing list