[gmx-users] gromp error for gmxtest-4.0.4 and 3.3.3 on new gromacs-4.0.5 install

Justin A. Lemkul jalemkul at vt.edu
Sun Nov 29 00:22:48 CET 2009

Yirdaw, Robel Birru wrote:
> Dear gromacs users,
> I have been attempting to test my new gromacs installation of version
> 4.0.5. using gmxtest 4.0.4 but I keep getting the following error message:
> ERROR: Can not find grompp in your path.
> Please source GMXRC and try again.
> I have sourced the GMXRC file - doing luck_d at the prompt works.
> I am simply following the instructions on running the test sets given at:
> http://www.gromacs.org/index.php?title=Download_%26_Installation/Test-Set
> I get the same error no matter what option I use - for instance, according
> to the instructions if you do ./gmxtest.pl you should get usage info, but
> I get the same error.
> I searched the mailing lists but couldn't find anyone with a similar problem.
> *My installation had no problems - it's a double precision install on
> ubuntu 9.04 and a Pentium 4 desktop.
> *I have also tried gmxtest-3.3.3, but I get the same error
> *However, trying gmxtest-3.3.2 does not give the error. Instead, testing
> begins, 16 simple, 14 complex and 63 kernel tests pass but interrupts with
> the following error:
> Error not all 45 pdb2gmx tests have been done successfully
> Only 0 energies in the log file
> It looks to me like there are multiple issues here. So my question is
> really simple, how does one test a gromacs installation?  What I am doing
> is actually a rehearsal for testing on a cluster.

If you only have a double-precision install, then the executable "grompp" does 
not exist, but "grompp_d" should.  The script expects the default, 
single-precision commands.  You can specify ./gmxtest.pl -double to append the 
_d suffix to all executables.


> Thanks.
> -Robel


Justin A. Lemkul
Ph.D. Candidate
ICTAS Doctoral Scholar
Department of Biochemistry
Virginia Tech
Blacksburg, VA
jalemkul[at]vt.edu | (540) 231-9080


More information about the gromacs.org_gmx-users mailing list