[gmx-users] tpi segmentation fault

Javier Cerezo jcb1 at um.es
Fri Aug 13 18:35:55 CEST 2010

Hi all.

I am trying to perform a tpi (test particle insertion) calculation on a 
trajectory generated with mpi_mdrun (gromacs 4.0.7, run in a Beowulf 
cluster of Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz). I am using 
tpi integrator in the mdp file and the following command:

  $  grompp -f tpi.mdp -c 32hoa_128dmpcwrun.gro -n index_tpi.ndx -p 
  $  mdrun -rerun 32hoa_128dmpcwrun.trr -g tpi.log

I tried different versions of gromcas and for 4.0.X I got a segmentation 
fault getting the message:

         trn version: GMX_trn_file (single precision)
         Reading frame       0 time    0.000   Segmentation fault

using a compiled version with "config --prefix 
/home/cerezo/Programs/gromacs4.07" + "make" + "make install". However, 
it works when I used a precompiled version (got with apt-get, I have 
kubuntu). So I guess that it may be due to a mistake during the 
compilation. In addition, other integrators (i.e. md, steep) work 
correctly with the version I've compiled. My system is and Intel(R) 
Core(TM)2 Quad CPU    Q8400  @ 2.66GHz. Is there any trick I could try 
in the compilation?

I also tried gromacs-4.5-betaX and it works but sometimes (apparently 
randomly) the calculation gets stops (as if it had entered in an 
infinite loop) after reading the last frame.

Thanks for your attention!


Estudiante de Doctorado
Dpto. Química-Física
Universidad de Murcia
30100 MURCIA (España)

More information about the gromacs.org_gmx-users mailing list