[gmx-users] problem with trjconv -pbc cluster

chris.neale at utoronto.ca chris.neale at utoronto.ca
Wed Jul 7 17:49:19 CEST 2010

Dear Jagannath:

There is, as far as I know, no way to fix this. Here's what you should do.

1. Let the space between your timesteps be X ps.
2. Use trjconv -pbc cluster -dump X -o out.gro
2b. if that doesn't work, try trjconv -pbc cluster -dump (X*2) -o out.gro
2c. if that doesn't work, try trjconv -pbc cluster -dump (X*3) -o out.gro
(Note use real numbers for args to -dump).

Once you have a frame that works, you can run part 2 and 3 of that  
wiki page by making a tpr based on the gro that worked -- and I think  
that you'll need to run your trjconv -pbc mol starting from the frame  
where clustering worked (e.g. -b X). Note that this second requirement  
means that you may need to reverse the frames from your .xtc file so  
that you can run in reverse time from a complete micelle through to  
disassembly with -pbc nojump -- a for loop around trjconv will work  
but inefficiently, you might be able to use -demux smartly here (I'm  
not sure).

But then since you have 2 micelles you will need a starting box in  
which they are both whole.... getting trickier. You should be aware  
that the trjconv -pbc cluster is not the only way to do part 1 from  
that wiki page. You could use trjconv -trans X Y Z and then make a new  
.tpr and then run trjconv -pbc nojump and it would work if only you  
knew which X Y Z to use (although trial and error may help you here  

Sorry this is confusing, but this is a difficult thing to do and you  
should expect to struggle with it for some time, so another questino  
to ask yourself is "do I really need to do this?" If its just for  
making a movie then you can use pbctools in vmd for that.


-- original message --

Hi,  I had a system of surfectants which are started with an initial  
configuration where all of them are well dispersed. Visual study of  
trajectory shows they start aggregating and finally form two discrete  
micelles. To quantify this micelle clusterization, I tried to use the  
suggestions present in the gromacs documentations:  
i.e    use trjconv -pbc cluster to obtain a single frame that has all  
of the lipids in the unit cell. This must be the first frame of your  
trajectory. A similar frame from some previous timepoint will not  
work.use grompp to make a new tpr file based on the frame that was  
output from the step above.use trjconv -pbc nojump to produce the  
desired trajectory using the newly produced tpr file.trjconv -f a.xtc  
-o a_cluster.gro -e 0.001 -pbc clustergrompp -f a.mdp -c a_cluster.gro  
-o a_cluster.tprtrjconv -f a.xtc -o a_cluster.xtc -s a_cluster.tpr  
-pbc nojump
But, The first step i.e. trjconv -pbc cluster does not work. Looks  
like it is going through an infinite loop and is not stopping for  
I am using gromacs 4.0.7
Any help will be appreciated.

More information about the gromacs.org_gmx-users mailing list