[gmx-users] the problem of gromacs-4.5.1 has been solved

Francesco Oteri francesco.oteri at gmail.com
Wed Oct 13 10:52:19 CEST 2010

I compiled both gromacs 4.5.1 and fftw 3.2.2 using icc.
I used the following command line for configure
./configure --prefix=/apps/fftw/3.2.2/intel/ --enable-single CC=icc 
./configure --prefix=/apps/gromacs/4.5.1/icc --with-gsl CC=icc F77=ifort 
CPPFLAGS=-I/apps/fftw/3.2.2/intel/include -I/apps/gsl/1.9/icc/include 
LDFLAGS=-L/apps/fftw/3.2.2/intel/lib -L/apps/gsl/1.9/icc/lib -L/usr/lib -ldl

PS. The flags -L/usr/lib and -ldl are required to enable VMD support 
since the installer is unable to link dl library. Obviously paths are 
relative to my system
On 13/10/2010 10:20, fancy2012 wrote:
> Dear GMX users,
> Yesterday I sent the following two mails to this archive, and now my 
> problems have been solved.
> Dear GMX users,
> I did some MD in parallel using gromacs-4.5.1, but it failed to work! 
> But it worked successfully when didn't use parallel version! It showed 
> like this: Will use 12 particle-particle and 4 PME only nodes
> I searched the archive, and I found that someone also have this 
> problem using gromacs-4.0.7. But I still don't find a effective way to 
> solve it. Could someone give me some suggestion? Thanks very much in 
> advance!
> All the best,
> fancy
> Dear GMX users,
> There is another question. Is there some problems of gromacs-4.5.1 
> when compiling it using icc, while compiling fftw-3.2.2 using gcc? Or 
> it is just OK?
> Thanks very much!
> All the best,
> fancy
> After I compiled gromacs-4.5.1 using icc, while compiling fftw-3.1.3 
> using icc, the parallel version of gromacs could run successfully. But 
> I am strange that I can't compile fftw-3.2.2 using icc, that's why I 
> chose gcc yesterday! Maybe there is a bug, or whatever!
> Thanks very much!
> All the best,
> fancy
> ------------------------------------------------------------------------
> È«¹ú×îµÍ¼Û£¬ÌìÌìÔÚ¼Ò³åÕÕƬ£¬24Сʱ·¢»õÉÏÃÅ£¡ 
> <http://yxp.163.com/photo/ep.html?sss=fromyx0911> 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20101013/d7034340/attachment.html>

More information about the gromacs.org_gmx-users mailing list