[gmx-users] segmentation fault while running eneconv

Anna Marabotti anna.marabotti at isa.cnr.it
Tue Jan 25 10:41:22 CET 2011

Dear all,
I launched on my system a first simulation of 5 ns, then I prolonged it to
50 ns using 
tpbconv -s tpr1_5ns.tpr -until 50000 -o tpr2_50ns.tpr
and then 
mdrun -s tpr2_50ns.tpr -deffnm md2_50ns -cpi md1_5ns.cpt
Since my simulation was interrupted several times, every time I relaunched
it simply doing:
mdrun -s tpr2_50ns.tpr -cpi md2_50ns.cpt -deffnm md2_50ns_2/3/4
At the end of these simulations I obtained the following files:
- md1_5ns.xtc and .edr: files obtained from the first MD of 5 ns long
- md2_50ns.xtc and .edr: files obtained by prolonging the first MD until
- md2_50ns_2.xtc and .edr: files obtained by restarting the previous
dynamics that was interrupted before 50 ns
- md2_50ns_3.xtc and .edr: same as before
- md2_50ns_4.xtc and .edr: same as before
After all these runs, I want to concatenate all the dynamics in order to
have a single .xtc file md_50ns_tot and a single .edr file md_50ns_tot.edr.
For the first, I used:
trjcat -f md1_5ns.xtc md2_50ns.xtc md2_50ns_2.xtc md2_50ns_3.xtc
md2_50ns_4.xtc -o md_50ns_tot.xtc
and all worked fine: I obtained the output file with no errors (there are no
errors also in the .log files)
On the contrary, when I tried to do the same with eneconv:
eneconv -f md1_5ns.edr md2_50ns.edr md2_50ns_2.edr md2_50ns_3.edr
md2_50ns_4.edr -o md_50ns_tot.edr
I obtained the following output:
Opened 2GH9openmod4_pH10_5ns.edr as double precision energy file
Reading energy frame      1 time  100.000
Opened 2GH9openmod4_pH10_50ns.edr as double precision energy file
Reading energy frame      0 time    0.000
Opened 2GH9openmod4_pH10_50ns_2.part0002.edr as double precision energy file
Reading energy frame      0 time 14900.000
Opened 2GH9openmod4_pH10_50ns_3.part0003.edr as double precision energy file
Reading energy frame      0 time 27800.000
Opened 2GH9openmod4_pH10_50ns_4.part0004.edr as double precision energy file
Reading energy frame      0 time 38800.000
Summary of files and start times used:
          File                Start time
2GH9openmod4_pH10_5ns.edr        0.000
2GH9openmod4_pH10_50ns.edr        0.000
2GH9openmod4_pH10_50ns_2.part0002.edr    14900.000
2GH9openmod4_pH10_50ns_3.part0003.edr    27800.000
2GH9openmod4_pH10_50ns_4.part0004.edr    38800.000
Opened 2GH9openmod4_pH10_5ns.edr as double precision energy file
Segmentation fault

Looking for some hints in the gmx-users list the only thing I found that
could be similar to my problem is this old message:
I see in the output error message that the start time for the first two
simulations is the same: could be this one the problem for my system?
However, I did use tpbconv each time to make restarts of my simulations, I
really don't know why the start time is 0.000 in the first two cases. 
Is there a problem in the results of simulations if these two simulations
have the same start time? Practically, what can I do to concatenate my .edr
Many thanks in advance and best regards
Anna Marabotti
Anna Marabotti, Ph.D.
Laboratory of Bioinformatics and Computational Biology
Institute of Food Science, CNR
Via Roma, 64
83100 Avellino (Italy)
Phone: +39 0825 299651
Fax: +39 0825 781585
Email: anna.marabotti at isa.cnr.it
Skype account: annam1972
Web page: http://bioinformatica.isa.cnr.it/anna/anna.htm
"When a man with a gun meets a man with a pen, the man with a gun is a dead
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20110125/d00d618b/attachment.html>

More information about the gromacs.org_gmx-users mailing list