[gmx-users] Strange behavior from g_sas

Mark Abraham Mark.Abraham at anu.edu.au
Wed Mar 30 11:05:53 CEST 2011

On 30/03/2011 5:58 PM, Terry wrote:
> Hi, all,
> I have four trajectories which I want to analyze Surface on. So I run
> for i in 1 2 3 4; do echo -e " non-Water \n Protein " | g_sas -f $i.xtc -s $i.tpr -o $i.area.xvg -n index.ndx -q $i.pdb ; done
> But the strange thing is, g_sas analyzed the first three trajectories, but gave a "segmentation fault for the last one.
> The only difference for these trjs is the number of water molecules, hence the box size(I used NPT.) . Then I doubt maybe the atom name I used can't be put in pdb file (some of them are 5 letters long, and I used gro file since the very beginning ). I deleted the -q flag and run g_sas again, seg fault again.
> After searching, I did this:
> source /usr/local/gromacs/bin/GMXRC
> Then g_sas worked fine( without the -q flag).
> But I've already sourced GMXRC.bash.

You've either got some other installation of GROMACS that you were 
using, or you changed your input files, or something about the machine 
changed. Unfortunately "segmentation fault" is just a generic error. 
Some idea what the output said before that might clue people in as to 
why that happened.


More information about the gromacs.org_gmx-users mailing list