[gmx-users] Strange behavior from g_sas

Terry terrencesun at gmail.com
Wed Mar 30 12:21:01 CEST 2011

Hi Mark,

The output is like this:

WARNING: masses and atomic (Van der Waals) radii will be determined
         based on residue and atom names. These numbers can deviate
         from the correct mass and radius of the atom type.

2565 out of 4931 atoms were classified as hydrophobic

Back Off! I just backed up sas/4.area.xvg to sas/#4.area.xvg.1#

Back Off! I just backed up sas/4.volume.xvg to sas/#4.volume.xvg.1#
There were 372 inconsistent shifts. Check your topology
There were 372 inconsistent shifts. Check your topology
Segmentation fault

I have a periodic molecule, so there are many "inconsistent shifts" lines
which I ignored before.

I still don't understand why g_sas can work with the first three trjs but
the last one in the same for loop.


On Wed, Mar 30, 2011 at 5:05 PM, Mark Abraham <Mark.Abraham at anu.edu.au>wrote:

> On 30/03/2011 5:58 PM, Terry wrote:
>> Hi, all,
>> I have four trajectories which I want to analyze Surface on. So I run
>> for i in 1 2 3 4; do echo -e " non-Water \n Protein " | g_sas -f $i.xtc -s
>> $i.tpr -o $i.area.xvg -n index.ndx -q $i.pdb ; done
>> But the strange thing is, g_sas analyzed the first three trajectories, but
>> gave a "segmentation fault for the last one.
>> The only difference for these trjs is the number of water molecules, hence
>> the box size(I used NPT.) . Then I doubt maybe the atom name I used can't be
>> put in pdb file (some of them are 5 letters long, and I used gro file since
>> the very beginning ). I deleted the -q flag and run g_sas again, seg fault
>> again.
>> After searching, I did this:
>> source /usr/local/gromacs/bin/GMXRC
>> Then g_sas worked fine( without the -q flag).
>> But I've already sourced GMXRC.bash.
> You've either got some other installation of GROMACS that you were using,
> or you changed your input files, or something about the machine changed.
> Unfortunately "segmentation fault" is just a generic error. Some idea what
> the output said before that might clue people in as to why that happened.
> Mark
> --
> gmx-users mailing list    gmx-users at gromacs.org
> http://lists.gromacs.org/mailman/listinfo/gmx-users
> Please search the archive at
> http://www.gromacs.org/Support/Mailing_Lists/Search before posting!
> Please don't post (un)subscribe requests to the list. Use the www interface
> or send it to gmx-users-request at gromacs.org.
> Can't post? Read http://www.gromacs.org/Support/Mailing_Lists
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20110330/32121219/attachment.html>

More information about the gromacs.org_gmx-users mailing list