[gmx-users] Broken protein after EM

Justin Lemkul jalemkul at vt.edu
Mon Aug 27 14:29:38 CEST 2012

On 8/27/12 8:27 AM, Shima Arasteh wrote:
> Dear gmx users,
> I'm simulating a protein in water. I ran these commands:
> 1.pdb2gmx -f monomer.pdb -o monomer.gro -water tip3p -ter
> 2.editconf -f monomer.gro -o monomer_newbox.gro -c -d 1.0 -bt cubic
> 3.genbox -cp monomer_newbox.gro -cs spc216.gro -o monomer_solv.gro -p topol.top
> 4.grompp -f ions.mdp -c monomer_solv.gro -p topol.top -o ions.tpr
> 5.genion -s ions.tpr -o monomer_solv_ions.gro -p topol.top -nname CL -nn 1
> 6.grompp -f EM.mdp -c monomer_solv_ions.gro -p topol.top -o EM.tpr
> 7.mdrun -v -deffnm EM
> Up to step 7 everything is normal. When I run the 7th command and then visualize the product of EM, the protein is broken into 3 distinct parts. Would you please give me your suggestions to solve?
> Is PBC may be the reason of such problem?

It usually is.  For simple protein-in-water systems, try:

trjconv -s EM.tpr -f EM.gro -pbc mol -ur compact -o EM_pbc.gro

Should do the trick.



Justin A. Lemkul, Ph.D.
Research Scientist
Department of Biochemistry
Virginia Tech
Blacksburg, VA
jalemkul[at]vt.edu | (540) 231-9080


More information about the gromacs.org_gmx-users mailing list