[gmx-users] Using groups in the mdp file

Justin A. Lemkul jalemkul at vt.edu
Tue Feb 7 01:25:39 CET 2012

Ignacio Fernández Galván wrote:
> --- On Mon, 6/2/12, Justin A. Lemkul <jalemkul at vt.edu> wrote:
>> Perhaps the OP can provide the original grompp command and
>> whether or not the -n flag was invoked.  An incorrect
>> index file can also give this error, I believe, if it does
>> not contain the desired group.
> I'm not using an index file. The grompp command line is simply:
> grompp -f dinamica.mdp -c equilibrar.gro -p topol-mod.top -o dinamica.tpr
> The .gro file does not contain any mention to "ACX", but I believe it's not needed, as long as it's in the .top, right?

Right, residue names are irrelevant.  Group names are dependent upon either 
[moleculetype] or index group names.

>>>> energy_grps          =
>> ACX
>> This is an incorrect keyword that should have raised a fatal
>> error.  The proper keyword is "energygrps."
> Perhaps both "energy_grps" and "energygrps" are valid? I tried with "energygrps" and I get the same error as with "energy_grps", and both work if I use "SOL" instead of "ACX".

Seems the code does not accept "energy_grps" unless there's some weird function 
I'm not aware of.  In any case, it's probably not relevant to your problem.  If 
you send me (off-list) your .gro, .top, and .mdp file, I will try to 
troubleshoot the problem and post back if/when I find it.



Justin A. Lemkul
Ph.D. Candidate
ICTAS Doctoral Scholar
Department of Biochemistry
Virginia Tech
Blacksburg, VA
jalemkul[at]vt.edu | (540) 231-9080


More information about the gromacs.org_gmx-users mailing list