[gmx-users] g_helix not recognizing protein backbone

Justin A. Lemkul jalemkul at vt.edu
Thu Mar 8 23:03:09 CET 2012

MPID wrote:
> I am running g_helix on a run involving a 37 residue protein in the charmm
> force field. It has two long alpha helical segments. I have tried running
> g_helix with many different variations of commands and getting rid of PBC
> effects, but I always get the same error:
> Checking group System
> There are 37 residues
> There are 0 complete backbone residues (from 0 to 524)
> -------------------------------------------------------
> Program g_helix, VERSION 4.5.5
> Source code file: /home/shared/installers/gromacs-4.5.5/src/tools/hxprops.c,
> line: 388
> Fatal error:
> rnr==0
> --------------------------------------------------------
> Is rnr the number of peptide residues, or the number that are helical? In
> either case, nothing I do can seem to make it different from 0. 

In the code, rnr seems to get reused a bit.  I think the problem may stem from 
the CHARMM force field itself.  Amide protons in CHARMM are named 'HN' while 
other force fields use simply 'H' and this is what the code checks for.  If it 
does not find an atom named 'H' then it will not detect that residue as being 

As a workaround, make a copy of your original topology and rename 'HN' to 'H' 
and re-compile a test .tpr file.  Try g_helix again using this .tpr file.  If it 
works (or doesn't), please report back.



Justin A. Lemkul
Ph.D. Candidate
ICTAS Doctoral Scholar
Department of Biochemistry
Virginia Tech
Blacksburg, VA
jalemkul[at]vt.edu | (540) 231-9080


More information about the gromacs.org_gmx-users mailing list