[gmx-users] OPLS specific problem in gromacs 4.5.4

Justin A. Lemkul jalemkul at vt.edu
Wed May 30 17:37:37 CEST 2012

On 5/30/12 11:32 AM, patrick wintrode wrote:
> After creating a box using editconf and then solvating using genbox, I try to
> add ions and get the infamous "number of coordinates in .gro does not match
> number of coordinates in topology" error.
> What's strange is that it only seems to happen when I am using the OPLS force
> field. I can type the exact same sequence of commands using the CHARMM27 force
> field and I don't get the error (unfortunately I want to use OPLS). Has anyone
> else encountered this?
> BTW, I tried dos2unix-ing my .mdp file before using grompp, but that didn't help.
> Any suggestions?

Can you verify that the contents of the coordinate and topology files indeed 
should match?  For instance, have you manually inspected them and counted water 
molecules, etc to guarantee they are the same?

If you are using different force fields, have you verified that you are using 
the right files that match the given force field?

Does the water model you solvated with match the coordinate file?  TIP3P is 
suggested for CHARMM, but TIP4P is suggested for OPLS, so the "same sequence of 
commands" might give different outcomes.

Have you tried your workflow with CHARMM and OPLS via a script, so that you know 
that what you typed in each case was exactly the same?



Justin A. Lemkul, Ph.D.
Research Scientist
Department of Biochemistry
Virginia Tech
Blacksburg, VA
jalemkul[at]vt.edu | (540) 231-9080


More information about the gromacs.org_gmx-users mailing list