[gmx-users] problem with plumed version of gromacs in replica exchange

Sanku M msanku65 at yahoo.com
Wed May 30 22:41:24 CEST 2012

Dear Users ,

  I am trying to use PLUMED with gromacs4.5.4 to perform umbrella sampling simulation using replica exchange as implemented within gromacs. I am using radius of gyration as the collective variable along which umbrella sampling is being performed. However, I find that whenever I try to run replica exchange with umbrella sampling using the plumed compiled gromacs, it always crashes saying that 

 "The properties of the 23 systems are all the same, there is nothing to exchange
For more information and tips for troubleshooting, please check the GROMACS
website at http://www.gromacs.org/Documentation/Errors"

I had generated 23 replica each corresponding to a particular temperature and then used grompp (compiled using plumed ) to generate 23 .tpr file. Now, I use only one plumed.dat file . But, running the simulation using command

~/UTIL/OPENMPI/bin/mpirun -np 46  mdrun_plumed_s -multi 23 -replex 500 -s hremd -plumed plumed_umb.dat >& log_replica

But, it ctashes..

I have also tried running regular replica exchange simulation without this plumed.dat file and then again it crashes saying the same error that it finds all replica identical.

However, same simulation with official gromacs 4.5.4 executable ( i.e without the plumed plugin) runs without any problem. 
Also, the plumed plugin works great for a single temperature simulation.

So, I wonder whether the plumed plugin is causing any trouble in running replica exchange simulation or I am missing something.
Thanks in advance for help
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20120530/8103c2c6/attachment.html>

More information about the gromacs.org_gmx-users mailing list