[gmx-users] libfftw3f.so.3 error known but not able to solve

Justin Lemkul jalemkul at vt.edu
Sun Nov 4 18:32:53 CET 2012

On 11/4/12 12:23 PM, gromacs query wrote:
> Dear Justin,
> Just to add: I can echo all variables (
> http://www.gromacs.org/Documentation/Terminology/Environment_Variables)
> except GMXLIB so my bashrc is like this: which is still not helping
> export GMXLIB=/usr/local/gromacs/share/gromacs/top
> export LD_LIBRARY_PATH=/usr/local/bin
> #export PATH=$PATH:$LD_LIBRARY_PATH (tried by including and not including
> this)

You need the LD_LIBRARY_PATH to find libraries, not executables.  My hint was 
that the mechanism worked like PATH, not that it should be joined to it.

Depending on your system configuration, LD_LIBRARY_PATH may already be set (so 
check by using echo to see what it is set to).  If it is not set, then:

export LD_LIBRARY_PATH=/usr/local/lib

If it is set already, then:

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib



Justin A. Lemkul, Ph.D.
Research Scientist
Department of Biochemistry
Virginia Tech
Blacksburg, VA
jalemkul[at]vt.edu | (540) 231-9080


More information about the gromacs.org_gmx-users mailing list