[gmx-users] g_tcaf segmentation fault

lina lina.lastname at gmail.com
Wed Sep 26 19:12:20 CEST 2012

On Thursday 27,September,2012 12:55 AM, Stelios Karozis wrote:
> Thanks for the suggestion.
> I just tried and the problem presists. 
> Just to be clear, the right way is to use the g_covar.trr file, correct? 

 -f       traj.trr  Input        Full precision trajectory: trr trj cpt

Here the full precision means double precision? I see you use single

I have never tried this one, perhaps someone else may give you some

Best regards,

> Ο χρήστης lina <lina.lastname at gmail.com> έγραψε:
> On Thursday 27,September,2012 12:13 AM, Stelios Karozis wrote:
>> The -dt flag is the time step between the frames in ps. I tried the command in any combination i could think of. With -dt without, with -b without, and so on. The only way i get a partial result is to use the .trr file from the simulation and not from the g_covar command and even then i get the density of the system and after that "segmentation fault"
> Segmentation fault involves lots.
> If I were you, I would try -dt 100 or large to reduce memory
> requirement. or perhaps try the very short time period. namely -e 200 to
> see what's going on.
>> Ο χρήστης lina <lina.lastname at gmail.com> έγραψε:
>> On Wednesday 26,September,2012 06:33 PM, Stelios Karozis wrote:
>>> Dear all,
>>> I am attempting to calculate the viscosity of a liquid binary system of
>>> 500 molecules (3050 atoms), via g_tcaf command.
>>> The system is equilibrated. The list of command I use is:
>>> /g_covar -f traj.trr -s topol.tpr -n index.ndx -o eigenval.xvg -v
>>> eigenvec.trr -av average.pdb -l covar.log//
>>> //g_tcaf -b 0 -e 20000 -dt 0.001 -f eigenvec.trr -s topol.tpr -n
>>> index.ndx -mol -oc tcaf_cub.xvg  -oa tcaf_all.xvg -o tcaf.xvg -of
>>> tcaf_fit.xvg/
>> -dt 0.001 ?
>>> The result is a Segmentation fault error:
>>> /Selected 0: 'System'//
>>> //trn version: GMX_trn_file (single precision)//
>>> //Last frame         -1 time    0.000/*/
>>> /**/Segmentation fault/*
>>> I use GROMACS 4.5.5
>>> What am I doing wrong?
>>> Thanks in advance
>>> Stelios

More information about the gromacs.org_gmx-users mailing list