[gmx-users] selecting res CYS from G53a5 using pdb2gmx

Payman Pirzadeh ppirzade at ucalgary.ca
Wed Jan 9 00:09:42 CET 2013

Dear Justin,
Thanks for the tips. Things worked smoothly up to the point when I wanted to
run an actual simulation. When I wanted to run grompp for a NVT simulation,
I got this error message:

Fatal error:
7 atoms are not part of any of the T-Coupling groups

I realized that that in my mdp file, I had:

Tcoupl              =  Nose-Hoover
tau_t               =  0.2                 0.2          0.2
tc-grps             =  Protein             SOL          CL-
ref_t               =  310                 310          310

I noticed that this warning is related to the CYA residue. So I added CYA as
a new group to the above list and problem was solved. But what remains
strange/scary to me is that I defined CYA in residuetypes.dat! Shouldn't
grompp consider the new residue as part of the protein? Won't this separate
temperature coupling of a residue and protein cause strange behavior?
Sorry for inconveniences.


-----Original Message-----
From: gmx-users-bounces at gromacs.org [mailto:gmx-users-bounces at gromacs.org]
On Behalf Of Justin Lemkul
Sent: January-08-13 3:55 AM
To: Discussion list for GROMACS users
Subject: Re: [gmx-users] selecting res CYS from G53a5 using pdb2gmx

On 1/8/13 1:37 AM, Payman Pirzadeh wrote:
> Dear Justin,
> Thanks for your suggestions. It all made sense.
> But I ran into a strange problem. I checked the mail list, and all I 
> found was about misspelling the force field name. I copied the whole 
> gromos53a5.ff directory into my working folder, copied the modified 
> .rtp, .dat and .hdb files into the gromos53a5.ff folder, and issued:
> pdb2gmx_d_mpi -f protein.pdb -p protein-CYA.top -o protein-CYA.gro 
> -inter -ff gromos53a5.ff but what I got was:
> Program pdb2gmx_d_mpi, VERSION 4.5.4
> Source code file: pdb2top.c, line: 239
> Fatal error:
> Could not find force field 'gromos53a5.ff' in current directory, 
> install tree or GMXDATA path.
> For more information and tips for troubleshooting, please check the 
> GROMACS website at http://www.gromacs.org/Documentation/Errors
> If I do not add the -ff option, the default pdb2gmx command works, by 
> opening the force field from the default path. I tried 'source GMXRC' 
> from my working folder, but same error pops up. I am not sure what I 
> am missing here?!

You're using the wrong syntax.  The option -ff should take just the prefix
of the force field directory, i.e. "-ff gromos53a5" which causes pdb2gmx to
search for a gromos53a5.ff directory.



Justin A. Lemkul, Ph.D.
Research Scientist
Department of Biochemistry
Virginia Tech
Blacksburg, VA
jalemkul[at]vt.edu | (540) 231-9080

gmx-users mailing list    gmx-users at gromacs.org
* Please search the archive at
http://www.gromacs.org/Support/Mailing_Lists/Search before posting!
* Please don't post (un)subscribe requests to the list. Use the www
interface or send it to gmx-users-request at gromacs.org.
* Can't post? Read http://www.gromacs.org/Support/Mailing_Lists

More information about the gromacs.org_gmx-users mailing list