[gmx-users] selecting res CYS from G53a5 using pdb2gmx

Justin Lemkul jalemkul at vt.edu
Tue Jan 8 11:54:54 CET 2013

On 1/8/13 1:37 AM, Payman Pirzadeh wrote:
> Dear Justin,
> Thanks for your suggestions. It all made sense.
> But I ran into a strange problem. I checked the mail list, and all I found
> was about misspelling the force field name. I copied the whole gromos53a5.ff
> directory into my working folder, copied the modified .rtp, .dat and .hdb
> files into the gromos53a5.ff folder, and issued:
> pdb2gmx_d_mpi -f protein.pdb -p protein-CYA.top -o protein-CYA.gro -inter
> -ff gromos53a5.ff
> but what I got was:
> Program pdb2gmx_d_mpi, VERSION 4.5.4
> Source code file: pdb2top.c, line: 239
> Fatal error:
> Could not find force field 'gromos53a5.ff' in current directory, install
> tree or GMXDATA path.
> For more information and tips for troubleshooting, please check the GROMACS
> website at http://www.gromacs.org/Documentation/Errors
> If I do not add the -ff option, the default pdb2gmx command works, by
> opening the force field from the default path. I tried 'source GMXRC' from
> my working folder, but same error pops up. I am not sure what I am missing
> here?!

You're using the wrong syntax.  The option -ff should take just the prefix of 
the force field directory, i.e. "-ff gromos53a5" which causes pdb2gmx to search 
for a gromos53a5.ff directory.



Justin A. Lemkul, Ph.D.
Research Scientist
Department of Biochemistry
Virginia Tech
Blacksburg, VA
jalemkul[at]vt.edu | (540) 231-9080


More information about the gromacs.org_gmx-users mailing list