[gmx-users] mdrun segmentation fault for new build of gromacs 4.6.1

Amil G. Anderson aanderson at wittenberg.edu
Thu Jun 6 22:56:59 CEST 2013

Gromacs users:

I have just built and installed gromacs-4.6.1 on my Xeon 5500 compute cluster running Centos 5.  The installation was done with gcc 4.7.0

I have run a simple test (the old tutor/gmxdemo) which fails at the first mdrun step with a segmentation fault.  The command line for this step is:

mdrun -nt 1 -s cpeptide_em -o cpeptide_em -c cpeptide_b4pr -v -debug 1

where I have included the debug flag and have restricted the run to one core.  The files associated with this run are located at:


I have done a test build of gromacs-4.5.4 (version I have been running the last year) with the same build environment as the 4.6.1 build, including using cmake.  The rebuild of gromacs-4.5.4 runs the demo completely.

Given the limited information for the run (segmentation fault seems to occur just after reading in the parameters), I'm not sure how to further pursue the source of this error.  I have also tried building gromacs-4.6.2 but have the same error for mdrun.

Thanks for any insight that you may be able to provide.

Dr. Amil Anderson
Associate Professor of Chemistry
Wittenberg University

More information about the gromacs.org_gmx-users mailing list