[gmx-users] Segmentation fault mdrun

Alex s as1783 at hotmail.com
Sun Aug 31 19:17:09 CEST 2014

I'd really appreciate some advice on this issue, I tend to get a segmentation fault during my mdrun. I've searched online for ways to resolve this and tried to diagnose whats causing this problem but I'm having no luck. 
I know that if you get a segmentation fault at step 0 its most likely a problem with system configuration or a minimization issue. However for my system I successfully run energy minimization and equilibration. When I run md the segmentation fault occurs usually very late on the system (past the 100ns mark).  
I've found that minor adjustments to the system can either lead to the error or remove it. For example for one system, I ran it ION free and I had no issues, however when I just replace 12 water molecules with NA+ and CL- this leads to a segmentation fault. Also I was able to fix this error in another system just by changing the time step from to 0.04 to 0.03.
>From what I'm describing, does it seem as if the fault lies with the system set up? or the mdp file? or could it be a compiler issue? What information should I be looking for in my output file to perhaps determine where issue lays?
Many thanks

More information about the gromacs.org_gmx-users mailing list