[gmx-users] installation and fftw3.h

Peter Palenchar peter.palenchar at villanova.edu
Mon Feb 10 19:33:13 CET 2014


I'm trying to install GROMACS 4.6.5 with cygwin. The quick and dirty instructions did not work because of an issue with the precision. I've used:


with the idea that GROMACS would build the fftw properly.

I then tried make, but got:

/cygdrive/c/Users/Administrator/Desktop/gromacs-4.6.5/src/gmxlib/copyrite.c:50:19: fatal error: fftw3.h: No such file or directory

#include <fftw3.h>

I've used the export commands to point where the directories are:

$ export CPPFLAGS=-"I/cygdrive/C/Users/Administrator/Desktop/gromacs-4.6.5/build/src/contrib/fftw/fftwBuild-prefix/include"

$ export LDFLAGS=-"L/cygdrive/C/Users/Administrator/Desktop/gromacs-4.6.5/build/src/contrib/fftw/fftwBuild-prefix/lib"

That seems to have worked:

$ echo $CPPFLAGS


$ echo $LDFLAGS


But when I use make I get the same exact error:

/cygdrive/c/Users/Administrator/Desktop/gromacs-4.6.5/src/gmxlib/copyrite.c:50:19: fatal error: fftw3.h: No such file or directory

#include <fftw3.h>

The content of the lib directory looks like this:


$ ls -l

total 2568

-rw-r--r-- 1 Administrator None 2625100 Feb 10 08:55 libfftw3f.a

-rwxr-xr-x 1 Administrator None 969 Feb 10 08:55 libfftw3f.la

drwxr-xr-x+ 1 Administrator None 0 Feb 10 08:55 pkgconfig

I saw on-line where somebody that made the fftw files themselves did it wrong and had the wrong files and therefore wrong names and had the same file names as I have, but I've also seen messages that made it seem like that their are installs where those file names have worked.

Any suggestions?



More information about the gromacs.org_gmx-users mailing list