[gmx-users] installation and fftw3.h

Christian Wagner wagner at mail.sysu.edu.cn
Tue Feb 25 03:26:24 CET 2014

I solved similar issues by installing FFTW, which goes rather quick: you can download and unpack the .tar then go to the directory, in which you unpacked and then build the single precision sse2 compatible library by './configure --prefix your/installation/path --enable-float --enable-sse2' followed by 'make' and 'make install'. After linking the lib folder to PATH Gromacs should find the library during the installation.

----- Original Message -----
From: "Peter Palenchar" <peter.palenchar at villanova.edu>
To: "gromacs org gmx-users" <gromacs.org_gmx-users at maillist.sys.kth.se>
Sent: Tuesday, February 11, 2014 2:25:43 AM
Subject: [gmx-users] installation and fftw3.h


I'm trying to install GROMACS 4.6.5 with cygwin. The quick and dirty instructions did not work because of an issue with the precision. I've used:


with the idea that GROMACS would build the fftw properly.

I then tried make, but got:

/cygdrive/c/Users/Administrator/Desktop/gromacs-4.6.5/src/gmxlib/copyrite.c:50:19: fatal error: fftw3.h: No such file or directory

#include <fftw3.h>

I've used the export commands to point where the directories are:

$ export CPPFLAGS=-"I/cygdrive/C/Users/Administrator/Desktop/gromacs-4.6.5/build/src/contrib/fftw/fftwBuild-prefix/include"

$ export LDFLAGS=-"L/cygdrive/C/Users/Administrator/Desktop/gromacs-4.6.5/build/src/contrib/fftw/fftwBuild-prefix/lib"

That seems to have worked:

$ echo $CPPFLAGS


$ echo $LDFLAGS


But when I use make I get the same exact error:

/cygdrive/c/Users/Administrator/Desktop/gromacs-4.6.5/src/gmxlib/copyrite.c:50:19: fatal error: fftw3.h: No such file or directory

#include <fftw3.h>

The content of the lib directory looks like this:


$ ls -l

total 2568

-rw-r--r-- 1 Administrator None 2625100 Feb 10 08:55 libfftw3f.a

-rwxr-xr-x 1 Administrator None 969 Feb 10 08:55 libfftw3f.la

drwxr-xr-x+ 1 Administrator None 0 Feb 10 08:55 pkgconfig

I saw on-line where somebody that made the fftw files themselves did it wrong and had the wrong files and therefore wrong names and had the same file names as I have, but I've also seen messages that made it seem like that their are installs where those file names have worked.

Any suggestions?


Gromacs Users mailing list

* Please search the archive at http://www.gromacs.org/Support/Mailing_Lists/GMX-Users_List before posting!

* Can't post? Read http://www.gromacs.org/Support/Mailing_Lists

* For (un)subscribe requests visit
https://maillist.sys.kth.se/mailman/listinfo/gromacs.org_gmx-users or send a mail to gmx-users-request at gromacs.org.

More information about the gromacs.org_gmx-users mailing list