[gmx-users] help with "interaction of type atom in the topology database, but an atom of that name was not found in residue" error

Justin Lemkul jalemkul at vt.edu
Mon Jan 6 22:30:44 CET 2014

On 1/6/14, 2:53 PM, paulxie wrote:
> Dear All,
> I noticed that there has been a few posts about this topic posted in this
> forum, but I have tried those proposed solutions and it still doesn't work.
> I have downloaded a force field, gromos43a1p (from
> http://www.gromacs.org/Downloads/User_contributions/Force_fields)  and
> installed it at my working folder. When I used pdb2gmx, I was able to find
> and use gromos43a1p for my target proteins containing phosphated residue(s)
> (downloaded from pdb website), but got the error message pasted below:
> Fatal error:
> Atom N is used in an interaction of type improper in the topology
> database, but an atom of that name was not found in residue
> number 1.
> Does anyone know what is the problem? Thanks a lot!

The most common source of error is not having added the names of the 
phosphorylated residues to residuetypes.dat.  See 



Justin A. Lemkul, Ph.D.
Postdoctoral Fellow

Department of Pharmaceutical Sciences
School of Pharmacy
Health Sciences Facility II, Room 601
University of Maryland, Baltimore
20 Penn St.
Baltimore, MD 21201

jalemkul at outerbanks.umaryland.edu | (410) 706-7441


More information about the gromacs.org_gmx-users mailing list