[gmx-users] Is version 5.0 generating portable binaries?

Raffaella D'Auria rdauria at ucla.edu
Thu Jan 30 23:52:03 CET 2014

Hello All,

I have just performed a fresh installation of gromacs version 4.6.5 on a heterogeneous linux cluster (running centos 6.4) . After the installation I see that the binaries, for say mdrun,  work on all the machines with hardware similar to the one on which they were installed (namely AMD processor such as: Quad-Core AMD Opteron Processor 2354) but produce an "illegal instruction (core dumped)" when run on nodes with intel processors (such as: Intel Xeon CPU E5335  @ 2.00GHz). 

As suggested in the documentation (http://www.gromacs.org/Documentation/Acceleration_and_parallelization#CPU_acceleration.3a_SSE.2c_AVX.2c_etc) I have tried to compile with GMX_CPU_ACCELERATION set to "none" (I have also turned down the optimization levels) with always the same result (illegal instruction) across different hardware. 

Is this expected behavior? If so will the binaries of version 5.* have the same portability problem?

One more thing the situation described above occurs with both the gnu 4.4.7 compiler and the intel 13.1.1.

Any feedback would be greatly appreciated.



More information about the gromacs.org_gmx-users mailing list