[gmx-users] Inserting required no. of water using genbox -ci -nmol crashing

Justin Lemkul jalemkul at vt.edu
Wed Jul 2 12:18:07 CEST 2014

On 7/2/14, 12:02 AM, shivangi nangia wrote:
> Hello gmx-users,
> This is regarding inserting required number of TIP3P water molecules using
> genbox.
> I have a system containing POPC, peptide, water molecules & ions.
> For some system set up, I had to delete all the waters and ions ( The box
> size was not changed). Now I  want to insert the same number of water
> molecules back into the box (35228) but the job keeps crashing. When I run
> it interactively it says there is not enough memory and if I submit in
> queue the job just exits or goes into zombie mode.
> System size: 9.38943   9.38943  15.54950
> command: genbox_mpi -cp  popc_pep.gro -ci spc.gro -nmol 35228 -o
> solvated.gro
> I have tried varied kinds of spc.gro containing just one water molecule, 2
> ,3 and 4 (system size fixed accordingly using editconf -d 0 )
> On using -cs option, lesser number of water molecules get inserted than
> 35228 on using the spc216.gro found in the /apps/gromacs/top folder.

That means there's not enough room in the box for that many waters in those 
given configurations.  You run out of memory because (1) using -ci -nmol is a 
horribly inefficient way to insert waters and (2) genbox simply can't find 
enough space, so it keeps going until system resources are exhausted.



Justin A. Lemkul, Ph.D.
Ruth L. Kirschstein NRSA Postdoctoral Fellow

Department of Pharmaceutical Sciences
School of Pharmacy
Health Sciences Facility II, Room 601
University of Maryland, Baltimore
20 Penn St.
Baltimore, MD 21201

jalemkul at outerbanks.umaryland.edu | (410) 706-7441


More information about the gromacs.org_gmx-users mailing list